Superscript adds to line spacing when creating PDF files


Thanks for creating Scrivener! It looks like it is going to fit the way I write papers for college quite well. The overhead in moving things around in Word generally leads to me leaving papers in sub-optimal ordering and with bad “flow.” It looks like Scrivener is going to help with that, and with keeping up with references, etc.

In writing my first paper with Scrivener, I have a small problem:
I’m using 2.0.5 (9496) on Mac OS X 10.6.7. I have a document with superscripts that were inserted automatically by Scrivener (thanks!), such as 14th, 5th, etc. The line spacing looks okay when I view it in Scrivener. When I compile to a PDF, the superscripts expand the line spacing beyond the normal double-spacing. If I export to an rtf file and open it in Word, it looks and prints fine.

Is there a way to fix the line spacing when compiling to a PDF?

Thanks for any suggestions!


Hi John,

Thanks for the kind words!

Testing this, I think the problem arises from overriding the font (in the “Formatting” options in Compile). In the Cocoa text engine, superscripting text doesn’t change the font size, but when Scrivener superscripts ordinals, I have it reduce the font size as well. However, once formatting is overridden, the font and font size gets overridden so that ordinals return to regular size. If you export to RTF and open in Word, it looks fine because Word automatically shrinks superscripted text; in a PDF, however, it does look wrong.

Which is a long-winded way of saying that I’m not sure how best to handle this. :slight_smile: Ultimately it’s down to the way that OS X handles superscript, but on the other hand I have Scrivener handle it correctly when the font isn’t overridden. Hmm…

All the best,

Thanks for the quick reply Keith!

It’s not a show stopper.
I thought it might be an option, or something I overlooked.

Take care,

Hi there

Hope I could post a related question to the one above on superscripts. I use a lot of superscripts in my writing, referring to manuscripts, which have recto and verso sides. So, ‘r’ and ‘v’ appear as superscript very often in my text, say ‘fol. 25r’. Since these are not ordinals, Scrivener doesn’t seem to be reducing font size, and as a result my writing space often has extra line spaces inserted. This isn’t a problem as such, but I don’t find it very pleasing to look at ( :open_mouth: ) as it seems to visually interrupt the text flow!

So: is there a way, or a setting, to force Scrivener to reduce every superscript to smaller size (a la Word), so that the line spacing remains constant throughout? Or is this dependent on line spacing itself?

Thanks for a brilliant product, and happy Easter!


Hi Sebastiaan,

Thanks for the kind words! Unfortunately there is no really easy way of doing this - it’s part of the way Apple’s text system works. Given that you have to do this a lot, the quickest way in Scrivener would probably be to set up two presets via the Format > Formatting menu - set up one with preset with no superscript (using regular font size) and one with (and a smaller font size). When you create the presets, you’ll want to choose only to save character formatting and font size. If you give the presets distinctive names that aren’t used elsewhere in the menus, you could then assign a keyboard shortcut to each via your System Preferences. That way, whenever you come to have to type a recto or verso signifier, you can just hit the keyboard shortcut for your superscript+small font preset, type “v” or “r”, and then hit the keyboard shortcut for your no superscript+normal font preset and carry on typing.

An even quicker way might be to use something like TextExpander, though. TextExpander allows you to set up sequences of characters that get converted to other text as you type, and it supports rich text - so you could have [v] set up as a superscript “v” for instance (you would probably want to add a space after that uses regular formatting so that when you carry on typing you aren’t typing in superscript.

I hope this helps - apologies if it’s a bit all over the place as I have just returned from an Easter day out with the kids.

All the best,

Many thanks (not least for getting to this on a bank holiday, surely beyond the call of duty :smiley: ). It hadn’t occurred to me to look outside Scrivener, but my Typinator has indeed sorted the problem, as you suggest. Great solution. Once more, my thanks,


Glad you found a workable solution!
All the best,