supersede police and size for a pdf compile

I’m using Scrivener 3.0.3.
My book is actually define in Georgia 14 all over, with header, title and text sections.
I’m searching for help about compile this book to pdf for a submit to amazon printing, but with a change to police size (and eventually police itself)

What I have done is:

  • call compile
  • define a new format
  • in the format:
    -> define a new page size page parameters=worked
    -> creating a new style with a police (same or not) and a size
    -> binding this style in each section layout and overwrite books settings
    Is not working at all at compile. I can see my section changed in the right design screen but when testing, the pdf stills use old size & police.
    I probably miss something somewhere, but can’t find it. If someone got any clue for me that will be great ! :slight_smile:
    thanks in advance for any answer.

By the way, the 3.1 beta comes with a new stock compile Format that is already set up for 6 x 9" scale. I’ve saved out a copy of it for you to try importing into your project settings (just drag and drop the unzipped file into your Format sidebar).

That aside, I’m unclear on what it is you mean by police, in this posting. But as a general tip, make sure that once you save your custom Format you double-check the Section Layout assignment settings. If you duplicated a layout and changed how the duplicate works, then it’s likely none of the Section Types in your book are using this new layout yet. (5.07 KB)

Ioa, I’m thinking it is “policy”. Ex: the policy specifies font, font size and margins. It made sense when I read it that way.

But I’m guessing.

I’m thinking the OP means “font”. Not sure why “police” is being used. A francophone might confuse “police” with “rule” I suppose, but I don’t think that fits the context.

Edit – just looked it up on Larousse, which says “Ensemble de toutes les lettres et signes qui composent un assortiment de caractères d’imprimerie de même famille.”

So it is “font”.

Note to OP – it is a false friend. The English word only means the forces of order, and does not have the secondary meaning that it has inFrench. :slight_smile:

ooooh yes sorry for my mistake, :blush: :laughing: of course I was talking about font and not “police” (I don’t know what cops will do for me to resolve this problem :smiley: )
Anyway thanks for your answers and your guess.
@AmberV I’m going to try it right now, and give you a feedback asap.

Ok @AmberV I tried this format, but I’m sorry, It’s not giving any different result. Font and font size used in the project are the one used for output, despite what I tried to apply in the format configuration for compile :cry:

It might help then to have a simple example of how you have things set up. Here’s how I would do it:

  1. Create a test project using the “Blank” starter, and add some lorem ipsum text with the same sort of folder/file arrangment in the Draft that you use in your main project.
  2. From the main project, right-click on your custom compile format and export it to a file.
  3. As you did with the beta format, drag and drop this exported file into the test project’s compile format sidebar to import it.
  4. Set up the layout assignments the way you want.
  5. Test compile and make sure it doesn’t work still.
  6. If the project is a good demonstration of the problem, then use the File ▸ Back Up ▸ Back Up To… menu command with the zip option enabled, and attach your example to a response here.

If the project does work, then compare what you did to how your main project is set up, and let us know what it took to get it working, if you can.

Alternatively you could open a private tech support ticket to send your actual project to, using an email address on this page. Just make sure to include the forum thread URL, so that whoever gets the message can let me know.

Hi @amberV, sorry for my late answer, time is running too fast. I had to find another way to push my book to amazon backend.
But I would love to make it work in Scrivener. So I tried again on a new project as you asked and got the same “no result”. You will find the zip attached.
thanks a lot for help. (390 KB)

Okay, there is an interesting condition in this project. If you’ll note in the Format sidebar, there is a yellow warning icon beside your format. This format has been copied from the original in such a way that it is using the same internal code as the built-in copy. A way of thinking of it is that Scrivener has two different answers to the same question—so there is bound to be some confusion there. I right-clicked on the custom format and chose the option to fix the internal IDs. That’s not the source of the problem to be clear, but there is no sense in leaving things this way.

The actual problem, I suppose, is that you are setting the font in the wrong place. I’m not sure, because I’m not sure what it is you want from these settings, but here is what you have:

  • A text editor where every single paragraph is assigned to a style. Generally speaking this isn’t how Scrivener is designed to be used. Styles are for exceptional text (like a caption). So when you try to change a font in Section Layouts, nothing happens, why? Because all of your text is very strongly declaring it should look the way it already does instead, thanks to being styled.
  • Styles can be flexible, despite that. But, you haven’t added a rule to your compile settings to do anything with this style. In the Styles compile preference pane there is no “georgia14” style listed. So that means it will just go on doing what you see in the editor. If you want it to be different, you need to add a rule for it here and change the formatting and other settings.
  • The “Section Text” section layout looks fine. You’ve set that all up correctly—it’s just again you do not have any normal/body text in your project. All of it is specifically styled. So these settings for transforming body text font will fail.

Attached is your sample project with a few fixes made to it:

  • The duplicate ID problem is fixed.
  • Look in the editor first. The “Chapter/Scene” sample file has no style applied to the body text. This is how Scrivener is meant to be used. I’ve left the “Chapter2/Lorem” file styled, so we can test how to work that way as well.
  • In Compile, the duplicate ID warning is fixed.
  • Note the Section Layout now colours text red. We just want something obvious so we can see when and how these settings work.
  • Edit the Format and click on the Styles pane. I’ve added your “georgia14” style to the list, and if you click on it you’ll see it has the same formatting as the Layout except the text is blue.
  • Click the Test… button in the lower left.

All right, the first chapter has red text. This is because in the editor its body text is left alone. The Section Layout uses red Helvetica text, so that is what we get. The second chapter ignores the Section Layout entirely because every paragraph is assigned to a style. The style settings take over, colour the text to blue but otherwise using the same formatting as the Section Layout.

So now you know how to fix it either way. I’d recommend removing your “georgia14” style as it makes your text less flexible. You can’t just pick a format and get a nice looking result. Every time you pick a format you’ll have to duplicate and customise it to have a special rule for your styled text.

Let me know if you have any questions. (390 KB)

ok, first thanks a lot, it seems not that easy.
I downloaded your sample but sorry… I did not found any modifications you mentioned in the sample you attached. When I open it, it looks like mine, and that’s all.
Anyway I understood what you said and try it by myself
It works on the lorem ipsum one. Fantastic. So I tried on my full book and… damned. :smiling_imp: Yesterday one update has been installed (3.1) and I could not compiled as the all soft crash :frowning:
But I saw it working on the sample so I guess the fact to remove the applied style in the edit part as you said and apply it at compile works. I will know it for my next book :slight_smile:

I think actually some strange things appears because my book was started under Scrivener v2, then I updated to v3 and when importing my book, I had to review some disappeared style…
Many thanks for your time and your interest.

Oops! I accidentally attached the original .zip you sent, rather than the modified one I was describing. :slight_smile: I’ve updated the original post with the zip. Glad to hear you got things figured out without the demonstration though.

I’m not sure, v2 didn’t have Styles at all, so we would expect there to be nothing at all.

:mrgreen: thanks :slight_smile: