Surprising Formatting Results

Here is how I have my project and formatting set up:

i.imgur.com/UQZM8OG.png

But when I compile, this is what I get (Chapter headings center justified):

CHAPTER ONE

CHAPTER TWO

The text for the Day of Sneeze Cabinet scene

CHAPTER THREE

The text for the Day of Sneeze Club scene

CHAPTER FOUR

CHAPTER FIVE

The text for the First Sneeze Meeting scene


I expected and desired this:

CHAPTER ONE

The text for the Day of Sneeze Cabinet scene

The text for the Day of Sneeze Club scene

CHAPTER TWO

The text for the First Sneeze Meeting scene
etc.


Apparently I still don’t understand the formatting dialog.

I have been able to get what I want by loading the Paperback Novel preset, then unchecking the title checkboxes and adjusting the paper size. I can see that my problem is that I needed a line for Text 2+.

i.imgur.com/yuVdWAF.png

So here’s my question: My setup said “Do this for level 1 text documents and all levels below that.” That failed. The setting above that works says “DO this for level 1 text documents, and do the same thing for text level 2 documents and all levels below that.”

I see no logical different between those two things, but the results were totally different.

If you had selected the third row down (of the Formatting pane) in your screen shot, I bet you would have found a “CHAPTER ONE” centered and then text below it in the example text window in the lower half. Starting from a novel template, it’s assuming you EITHER set up your binder as you are doing it, OR you have a series of level 1 chapter files, but no folders.

The extra Level 2+ document row is there to account for scene documents in chapter folders, yet allow for people to use a flat chapter-file organization with nothing but Level 1 chapter files.

Make sense?

Yes, that’s indeed what I saw, and that makes sense. But I don’t know why that would cause it to display two chapter headings without any text in between. I’d expect it to come to the folder and say “OK, I’ll put up a CHAPTER ONE,” then come to the text, and say “OK, now I’ll print the text,” instead of “OK, now I’ll put up a CHAPTER TWO.”

Thanks, but I’m still missing something. By using “1+” I thought I was saying "Do this for all text documents, no matter what level they are (or, as the manual says “and anything deeper in the hierarchy than that.”). That’s what I wanted. Why do I need to specify something specifically for level 2 text documents?

In other words, from my understanding of the manual:

but apparently they are not.

Yes, you’re understanding the “+” indicator correctly. The problem was that you had a “Chapter <$t>” prefix for the Level 1+ document row. In the Paperback Novel preset, that prefix and the title are included for the Level 1 row but not for the Level 2, thus it fixed the issue. Removing the prefix from the Level 1+ row would work the same.

Yes, that was it, thanks. So, even though the “Title” checkbox wasn’t checked, it was displaying the “title prefix” thing. There’s got to be a better way to organize the Compile/Formatting system.

I believe the “Title” checkbox refers to whatever you’ve named the Chapter folders/Scene documents in the binder. So, if your first chapter folder/document is named “Jon Goes to Work,” and you have the “Title” checkbox checked, you should see:

                                 Chapter I

                         John Goes to Work

Without it checked, you would just see the “Chapter I.” That’s assuming that you have set it up to say Chapter I in the compile options for that level of document/folder.