Sync Error 4: The file doesn't exist

I just updated my desktop software to 2.8, and everything looks fine on my desktop. I’m trying to load two projects onto the new iOS app.

I don’t have any trouble adding them to Dropbox and syncing them with Dropbox on my iPad.

When I tried to import the files from Dropbox to the iOS app, the syncing hung up at the end, and now I see this error message: “Could not complete Dropbox operation. Error 4. The file doesn’t exist. (The file doesn’t exist.)”

I followed the suggestions on the website for troubleshooting. I closed all the apps on my iPad, then powered down the iPad and restarted it. Then I went to place in my house where the WiFi is strongest and tried again. This time instead of seeing a few hundred files trying to sync, I saw just “2 of 5.” It only got halfway through before giving me the same error message as before.

Next I decided to try to sync only one project, the smaller one, which is only 2.4mb. Same result.

Any suggestions?

If you’re seeing the two of five message, then the projects probably synced or mostly synced. I’ve synced five projects so far and typically the initial sync is a few hundred files and subsequent ones are fewer than a dozen or so. Obviously this will vary depending on how much editing you’ve done but the hundred + is typically only in the first sync.

But I’d recommend deleting them from Dropbox and recopying from your originals or backups. It sounds like something didn’t sync completely at some point in the process and it will be easier to start fresh .

But I DID delete. First I deleted them from Scrivener iOS, then from Dropbox. Then I uploaded them again to Dropbox, and then tried to send them to the app. I did that whole process three times and got the same “file doesn’t exist” error message.

Maybe I should delete the app and install it again?

Have you tried opening (and hence updating) the projects on the Mac in 2.8 before trying to sync to iOS? Maybe they are in an older version & the error message is because the iOS sync is expecting a file that isn’t in the older version projects?

Have you checked on your desktop that the whole Scrivener project is updated on Dropbox before testing on the iOS app, i.e. have the green symbol and not the red?

Hi Angelique, and I wonder if you’re clear that this all works differently from the way it used to on a Mac?

I also have a ‘hot tip’ at the end, but let’s make sure about your overall setup, especially because you sound like a capable person who may have used Mac or PC syncing in the past.

Now, your Mac-side Scrivener project is the one in the Dropbox/apps/Scrivener folder.

That’s the project you want to have moved there, and opened once by the new Scrivener, to convert it, before you try to sync and open it from the iPad side.

There’s no ‘uploading’ or ‘syncing’ from the Mac (or PC) side. You only use the Sync button there if you think the project was edited from the iPad side, and hasn’t automatically caught up because you had it open on the Mac/PC at the same time. And you never use the ‘external folder’ ability used before, when the project was in a separate place.

You can see this is quite different from before, again as you sound experienced.

Now, there is the one further thing, undocumented so far. (!)

Before you can sync successfully on the iPad side, you may need to make an edit on the Mac (or PC) side.

I’d just change the order of two documents in the binder, then close Scrivener to be sure the small result is saved, since we’re verifying. You can change the order back later, and usually wouldn’t have to worry about even such a small thing getting saved and noticed…

Then give some interval to let the Internet work, getting the changes from your home to Dropbox’s server, usually some seconds but can be longer, and try syncing once again on your iPad.

If the connections are really slow you may have to try several times, but it really should work this time – I think the Scrivener syncing is really good.

Best fortune, and of course come back (and get in touch with Support) if somehow it doesn’t.

Oh yes. This ‘hot tip’ is because of a fault that can happen sometimes with conversion, which has just been found and is getting fixed, validated with Jennifer (the charming Mouton) at Support.

Kind regards,
Clive

One other user reported this same sync error, and I currently have no idea what could cause it. It’s a generic internet connection error that suggests Scrivener is trying to download a file that doesn’t exist on the server. This shouldn’t be possible, however, because when Scrivener syncs, it asks Dropbox what files are available and then only downloads what Dropbox says is there. The only reason I can think of for this happening is if a file disappears from the server before Scrivener downloads it. But that can’t be the case if you have tried multiple times. It would be possible for there to be a bug in Scrivener where it deleted a file from the server and then tried to download it, I suppose, but Scrivener only deletes files from the server if they previously existed locally and were deleted, which won’t be the case here. And besides, that would only happen on one sync, not repeated attempts.

I suggest clearing the sync cache and restarting Scrivener. Here’s how:

  1. Open Settings app and open the “Scrivener” entry. (If the Scrivener settings are blank other than for the Photos entry, restart Settings app by double-tapping on the Home button and swiping up on Settings app to close it, then tap on Settings app to open it again. There’s an Apple but whereby Settings doesn’t show the options for newly-installed apps.)

  2. In Scrivener’s options in Settings app, tap “Reset Scrivener”.

  3. In the “Reset Scrivener” options, turn on “Clear Dropbox Sync Cache”.

  4. Quit Scrivener by double-tapping the Home button and swiping up on Scrivener in the row of apps.

  5. Open Scrivener again.

  6. Now try syncing again.

In order to determine what to sync efficiently, Scrivener has to keep a local cache of Dropbox folder state the last time it synced so that it can compare it against the state of files when you sync. The above steps wipe that file and cause a complete re-sync the next time you sync.

By the way, when you said “I tried to import the files from Dropbox”, I assume you just mean by tapping sync, and not using the Dropbox app in any way? (Some users have tried to copy .scriv projects using the Dropbox app which can cause problems. I don’t think that is your problem, though.)

All the best,
Keith

Using suggestions from narrsd and KB, I was able to get my project on my iPad! Here’s what I did:

  1. On the iOS app, I cleared the sync cache and restarted Scrivener.

  2. I opened my project on my Mac from the Dropbox folder and made a small change (reversed the order of two files.)

  3. Then I synced from my iPad. My project appeared and can be opened and edited.

Thanks!

Very strange! I’m wondering if there was some sort of error or conflict on the Dropbox servers, and so changing the file re-uploaded the files to Dropbox and cleared the glitch. That’s pure speculation, though. I’m glad you’re up and running!

All the best,
Keith

Most welcome, and glad to hear it :slight_smile:

You probably know KB is the guy who did as good a imaginative job as ever could be done, of designing this, and in course of time, getting that design interwoven with coded reality.

I’m glad both of these tips are up together, for others to find. I’m not sure if my ‘shift order first before sync’ extra step is necessary on the Mac, but at present on Windows it surely can be.

In regards to Keith’s speculation, I also had an upset last night which really looked like a Dropbox problem, and could use his cache reset as part of recovering it, if that is another story.

Take care, and am sure you’ll enjoy what you’ve got.

Clive