Sync failed error message, cannot creat a local directory

I’ve been using Scrivener on both Mac and iPad for years with no major issues. However when I went to open my latest project on my iPad I got an error message saying Sync failed. An error occurred when trying to create a local directory. The file XXXXXX (it’s a long, complicated number) doesn’t exist.

There are red x marks beside 4 files, one of which I haven’t even opened in over 6 months. When I click on the project it says it contains syn errors because it’s not fully downloaded.

I don’t understand why because I’ve done nothig differently to all the other times I’ve synced and opened projects on my iPad. All my software is up to date.

I’m afraid of trying to open anything in case I mess up the work on my Mac.

Advice appreciated.


How many times have you tried to sync iOS Scrivener?

I’ve synced successfuly multiple times over the past 10 years. But each time I try now (over a dozen times) I get the same message.

What changed? New version of Mac OS or iOS? Change to your internet connection? Change to your Dropbox account?

You can protect the work on your Mac by using the File -> Backup -> Backup To command in Mac Scrivener to make a backup to a non-Dropbox location.

You can protect the work on the iOS device by tapping the Edit button above the project list, selecting the project, and using the Export command to email an archive to yourself.

A troubleshooting guide for iOS synchronization can be found here: … os-syncing


Hi Katherine

Nothing has changed as far as I know. My internet connection is fine. My Mac and iOS update automatically but have always done so and there’s never been an issue. They are both running the most up to date versions. My projects are saved in the Apps/Scrivener folder in Dropbox (using the dropbox app locally on the Mac) and are backed up to a non-Dropbox folder. The message I get is that the sync has failed because ‘an error occured when trying to create local directory’ and then is tells me that the file doesn’t exist.

I’ve looked through your troubleshooting (I did this before I posted) and as far as I can see all my settings are fine and haven’t changed.

I tried to open one of the projects on the iPad and got the message that the project had sync errors. I tried to open it anyway and the message is "Invalid project. The project canno be opened because it does not contain a valid binder structure file. Please ensure the project has been fully uploaded from other devices and then try syncing with Dropbox again’

This message relates to the most recent projet which I hadn’t tried to open on the iPad before but also relates to 5 other projects that I have worked on before on the iPad and for which no message has ever appeared before. Some of the other projects I haven’t even opened in months so I haven’t changed them in any way at all.

I’m at a complete loss.


Have you looked at them from the Mac side, Reveal package content?

Have you made sure that you didn’t run out of space on Dropbox, or if some of your Dropbox settings have changed? You see this best from the web interface.

I haven’t run out of space on Drobox. I can open the files from the Dropbox folder on my Mac and everything is fine. But on these files theres a red x on the iPad and I can’t open them.

Please make sure your Mac backups are current, then use Finder to move the projects on the Mac out of the Dropbox folder.

Allow Dropbox to synchronize to the server, and then attempt to synchronize the iPad again.

This may result in the iPad projects disappearing. If it doesn’t, then either delete them or move them to the “On this iPad” section and synchronize again.

On the Mac, create a new test project in the Dropbox folder. Add a few files with a few lines of text, close Scrivener, and allow Dropbox to synchronize.

Using a browser, go to your account at, and confirm that the project is there.

If it is, synchronize the iPad. Was that successful?

If so, add a few lines of text to the project and synchronize it back to the Mac. Does that work?


Hi Katherine

Thank you, that worked… It was a bit nerve-wrecking because even though I have a million backups they were two very big projects and I was terrified of losing them!

thanks again