sync stalled

I have twice experienced the same problem : on one device, the sync is blocked after synchronising a few files (ex: “Syncing 5 of 9 files”) and nothing happens. (Scrivener is not opened on another device).
So far, the only solution I have found is to delete the app and re-download it. Is there another, less drastic, solution?

(And now, I have “Syncing 21 of 20 files”!)

What happens if you just close and re-open the app?

It is still blocked somewhere before completing the whole sync (right now on my iPhone , blocked at 3 of 6 files, after I have used and synced on the iPad and quit the app).
Although, this time, after I killed the app on the iphone, I could open it without being prompted to sync.
The problem is that I am uncomfortable: were all the modifications made on the iPad imported on the iPhone?
I should add that so far, I have encountered this problem only on the iPhone, not on the iPad.

Are you syncing the iPhone via WiFi or the mobile net?

wifi
My feeling is that there must be a bug affecting sync on the iPhone. Because again, I solved the last issue by deleting the app and reloading everything from scratch from Dropbox.

Try double tapping the home key, swipe up and ‘off’ the app from the app selection panel. Then restart the app. That might do the trick.

If it was a bug everyone running it on their iPhones should have the same problem, and they don’t. So it must be something about your specific setup - version of iPhone, version of iOS, size of available memory, etc - or something about your project in relation to your iPhone.

Try connecting the device to a power source; sometimes services like Siri only work properly if they’re not running off batteries.

This is a long shot I’ll admit.

Thanks for the advice. I keep hoping it will not happen. So far, at least, no file was lost, it seems…

There’s always the old fashioned way of printing things out on actual paper in the event of ultimate computer failure.

Well, I keep having problems with syncing to and from Dropbox, both on the iPhone and the iPad, and on two different projects.
Fortunately, I saved them on the Mac, but having the syncing process blocked in the middle and then, a time-out is kind of unsettling.

Do you have any VPN ad blockers installed? I’m beginning to think some of my synching issues stem from that.

I have had instances where sync seemed to stall out part way through, but a very close examination revealed that there was some pixelwise increment happening on the razor thin progress bar, and sure enough patience proved it true. What caused these slow-outs in my Dropbox sync, I don’t know. I chalked it up to server slowage, and it has only happened infrequently.

However, when I first encountered the phenomena, I spent a good deal of time retrying things. Truth is, I was killing the sync every time, because I mistook the slowdown for a hangup.

Just saying.

gr

@yosimiti I do have several VPN installed, but they were not activated.

@gr I doubt it is only a slow progression, at least in some instances. In any case, after some time, there is a time-out message. Moreover, that would not explain the strange message I see sometimes “Syncing 21 of 20 files”.

try deleting the vpn completely and utterly. they might work their demons even when they’re not on. anything that barricades the net in some fashion might affect syncing as far as I’m concerned. also check your firewall, network settings. sometimes things maybe haywire there.

After a week of trial and error, I have found -so I believe, at least- two ways of solving this problem, which are not fully satisfactory, but they work:

  1. delete the app, re-download it and synchronize with Dropbox. Whatever problem I had with syncing before disappears when I sync for the first time with the app for the first time after reinstalling it.
  2. when it is stalled, cancel synching and do it time again until all the files are synced and the app displays the message saying everything is in order.

It is a bit disturbing to see each time a different number of files to be synced but it seems that in the end, all of them are properly in place and there is no loss of data…

Silly question, but are you leaving the app open, and the screen on while it syncs?

When I first loaded Scrivener on my iPad I had like 2.1k files to sync and it was taking forever. So I closed my case (and it put the screen to sleep) and promptly paused the sync. Later when I opened it back up and saw it hadn’t finished, I switched apps and again, it promptly paused syncing while it was not the active app.

If neither of these things effect you, it might be you have a connect related issue. Have you tried a forced restart on your iDevice? Hold the screen sleep button until the swipe to power-off appears? WiFi networks get cranky if there are a number of them nearby and sometimes the little brains that manage the session keys get tripped up. If its available on your device, have you tried sync on mobile data to see if its just WiFi thats causing you trouble?