Sync with external folder is freezing Scriv

Hello,
I have just tried setting up sync with an external folder.
There appears to be one file that causes the whole application to lock up. I have to force quit to get out of there.
I have identified the file. And I see nothing odd about it. It has one inline footnote in it, and if I remove the footnote, then the sync issue does not occur. If I paste the footnote back in, the same issue reappears.

What’s the best way to go about trying to resolve this?

Thanks,

Jonathan

There could be a bad character inside the footnote itself. I would try re-typing it from scratch with a new footnote and see if it the problem goes away.

Hi Amber,
Thanks for assisting.
I also though maybe something was malformed or at fault in the footnote. So I deleted it and rewrote it, but it made no difference.
It seems as soon as I add an inline footnote into that file, even with just a few letters in it, it causes sync to hang Scriv.

Looks like a bug to me.

Here’s what I have discovered…
My footnote is between two words that are in italics.

If I have an inline footnote within text that as italics applied to it, that’s when the sync breaks.

Here is how I tested that. I put an incline footnote into a sentence with standard formatting (no italics). I just used “Test” as the footnote. I sync, no issue. Then I italicise the word before and after the footnote and sync breaks.

Interesting, I have tried to apply your conditions to a test file and didn’t run into any issues. There was no hang, and synced RTF files have correct formatting (verified in LibreOffice). There must be some other condition involved in the bug, it does sound like you’re on to something though.

A few things I can think of, you may think of others:

  • What font is being used for the text in the editor.
  • What sync file format are you using (as I noted, I tried with default RTF).
  • I would also try creating a simple blank test project set up with the conditions you describe, and see if it happens there. I would type in some test text, rather than copy and paste, to make sure it isn’t a formatting issue elsewhere in the original file.

Hello Amber,
Yes, it is rather odd.
I just tested it again… same result.
With the inline footnote either between some italic words or even directly after an italic word, it locks up. Remove those foot notes, and it’s fine.

In answer to your questions:

  1. Font is Georgia
  2. Format is .fountain

Here are some visual samples, for whatever they may be worth…
PastedGraphic-1.png
PastedGraphic-2.png
(both of above scenarios synced fine)

PastedGraphic-3.png

(answer to question 3 is in next post, as I reached my file attachment limit)

(answer to question 3)

  1. Here is samples from the new project test.
    I set up a new project. I wrote some text. I ran three tests:
    a) Sync as it. No issue.
    b) Sync with an inline footnote (no italics before or after). No issue.
    c) Add inline footnote into some italicised text. Eternal rainbow call of death. Locked up.

Following picture shows 1) the footnote I added for the b) test.
And 2) the footnote I added for the c) test.
new-file-test.png

Hello. Are there any updates or further thoughts on this?
If not, would you please log it as a bug?

Thanks,

Jonathan

Sorry for the delay, it seems the missing ingredient was in fact that Fountain format. Once I tried mixing italics in with footnotes, I ran into the hang just as you described it.

So, thanks! I’ve got it on our list of things to fix.

Great. Glad to hear it’s reproducible, and thus fixable at your end.
It’s funny how these obscure little bugs can show up. :confused:
All the best…
Jonathan

That it is indeed. Given the nature of it, I bet it’s been around for quite a while. There are probably not many people who use Fountain, footnotes and italics together. :slight_smile:

Am I correct in assuming Fountain is the best way to work with Markdown formatting? That’s what my Android based editing app works in, and it will deal with .md and .markdown and .fountain, etc. But .fountain seems to be the only Markdown related extension Scrivener handles. Is that correct?
Or will Scriv parse Markdown formatting in .txt files too? (actually, I am assuming it even parses the Markdown in .fountain files, as I’ve not fully tested that in both directions yet)

No, Fountain-format files must end in the suffix .fountain for Scrivener to recognise and parse them. However, be aware that Scrivener does not implement the current Fountain specification at the moment. At least one of the short codes is missing.

So with that in mind… I decided to invest a little time in finding out what Fountain is. I was aware if was related to Markdown, and as it’s the only Markdown related format Scriv seems to import/export with folder syncing, I’ve set my syncs up to use it.

I now see, however, that Fountain was inspired by Markdown but it not strictly speaking a Markdown formatting system. It is screenplay orientated “markdown” inspired formatting.

I need to run a few tests and see if my Android edited/created Markdown files are being parsed correctly (or at all) by Scriv upon import.

Has there been any discussion (that anyone reading this knows about) on Scriv supporting pure Markdown? :question: