Syncing External Folders and Paragraph Indents

I poked around and couldn’t find the answer I was looking for, so here goes. I’m syncing as plain text to an external folder in Dropbox where I can then turn around and pick up those files in IAWriter on my iPad and work on them away from my desktop. All of that is working as advertised. When I load the project in Scrivener back at my desk, it notices the file changes and imports them. Awesome.

The issue I’m having is with formatting and paragraph indentation on import. I have the “Automatically convert plain text paragraph spacing” box checked, so I’m getting a blank line between paragraphs in the text documents. The problem becomes when I import files back in using the same convention. Scrivener does indeed strip the blank lines between paragraphs, but it doesn’t seem to do much else. The new text I’ve added has no formatting once imported back into Scrivener.

I know that importing and exporting plain text can’t translate formatting (like bold, italic, etc…), what I’m talking about is the plain text looks nothing like the rest of my project. Each paragraph starts on the next line with no space between and no indentation. At least there’s a newline for each one, but they look like one, giant run on. Scrivener is not even applying its default formatting to this new text, which is what I expected.

When I try Convert -> Formatting to Default Text Style, everything at least shows up in the correct font, but it all still just runs together. Short of retyping everything, how do I get Scrivener to format my plain text like everything else? I’m not looking for special formatting, I just want this new work to be in the same format as the rest of my manuscript.

Thanks in advance for any help. Sorry if I missed something obvious. :slight_smile:

The way it works out how to apply the formatting to the document is to look at the most common paragraph formatting throughout the document and apply that. I’m using this same technique for editing files on my iPhone at the moment, and this is working as expected for me. How are the files formatted before syncing?

All the best,
Keith

As a programmer, that absolutely makes sense. :slight_smile: The few documents that I only changed a word or a line or two worked as I expected. Which, sadly, is a nice surprise for most software, so thanks for that. :slight_smile:

In this case, I have outlined my manuscript with folders and scenes using empty documents as placeholders, and I started work on a completely new scene from the iPad. So there really was no formatting when I started. It was just an empty text document. I guess because it had no formatting at all, and I applied none (IAWriter is just a plain text editor for this purpose), I expected it to use the style of the rest of the manuscript.

Is there any way now to get it into the same format without retyping? How can I sidestep this in the future?

Got it! If you create a new document on the iPad and sync it back with Scrivener, the formatting should be fine. However, it turns out that if you create blank documents in Scrivener, sync those with an external folder, and then add text to these blank documents externally (e.g. via the iPad), when they sync back they come in with no formatting - Scrivener was failing to check for this case. I therefore assume, from what you say, that these were all blank documents created in Scrivener which then had text added to them on the iPad.

I’ve just fixed this for 2.3. I’m hoping to put up another public beta ( https://forum.literatureandlatte.com/t/scrivener-2-x-update-betas-download-here/11262/1 ) by the end of the day, so you should be able to test this later.

Thanks for bringing this to my attention!

All the best,
Keith

Yay, an actual bug! As a fellow developer, I always hate having to post what MIGHT be a bug only to discover it was my own incompetence. :slight_smile:

And yes, you are correct. I had created blank documents when I started the project to outline my chapters and scenes, and I’ve been filling them in from there. Last night was my first attempt at writing on the iPad and syncing back, and I just got lucky hitting a bug I guess. :slight_smile:

The only thing I found lacking with the experience was the inability to see my document / project notes while working away from my desktop. I’m currently syncing only my Draft, and it looks like Scrivener will sync all the rest of my documents as well, but I assume they will not have their notes available either. Is there any way to get my notes within Scrivener to export somewhere? I guess I could move them all out to SimpleNote or Evernote or the like, but I do rather like keeping them all together. I wouldn’t bring it up in this topic, but since I have your attention. :slight_smile:

Thanks for the quick response and bug fix. Really appreciated.

There’s no way to sync notes, no - that’s one of the many reasons we are working on our own iPad/iPhone version. :slight_smile:

All the best,
Keith

Oooh… I dared to dream but didn’t want to pester. I’m sure the request has come in at least twice before. Is there a forum / topic or blog where one can follow the development of this magical unicorn and maybe know when it would be ready? :slight_smile:

There is in fact a place to post your suggestions for this beast:

viewforum.php?f=36

We’re still in the early stages, so it won’t be ready until much later in the year, but the plan is to have it out by the end of 2012 (we have a habit of missing deadlines we set ourselves :slight_smile: ).

All the best,
Keith

The beta that should fix your formatting issue is now up:

https://forum.literatureandlatte.com/t/scrivener-2-x-update-betas-download-here/11262/1

All the best,
Keith

Hey, Keith. I grabbed the beta and dropped it in for a test.

While it does appear to import the contents of the text file in the default text format now, I’m still not seeing paragraph indents or spacing. Just to be clear, my standard document looks like this:

    Some paragraph here.

    "Maybe some dialog here?"

    Another paragraph starts here.

I know the indents and space between paragraphs are just Scrivener displaying things and are not actually embedded in the project (as far as I would guess), so it’s just displaying things in a readable format more akin to the way the compiled output will look. But when I import a plain text document that was previously blank, I get:

Some paragraph here.
"Maybe some dialog here?"
Another paragraph starts here.

While the extra lines are properly removed, Scrivener doesn’t seem to know that it’s supposed to display each of those as separate paragraphs and instead leaves them butted against the left side and with no space between the paragraphs. Making them perfectly unreadable. :slight_smile:

Did I miss something when I did the sync? I get the right font and look with your bug fix, but I’m still not seeing proper paragraphs it would seem.

Hi,

I can’t reproduce this - all my paragraphs are coming in as expected now:

(That was a blank document in Scrivener, with the blank plain text file edited internally and then resented.)

Could you walk me through exactly what you are doing?

Thanks and all the best,
Keith

I checked again to make sure I was running the new beta, and that looks good.

I have a project I’m already working on. In that project I have many blank documents. There is a corresponding blank .txt file in my sync directory for each of those blank documents. In the simplest test case, I opened the blank .txt file (in MacVim if it matters, perhaps a line-ending issue, but I can’t imagine since I’m not touching Windows and their horrid \r\n business) and add a few lines like so:

A paragraph here.

Another one here.

One more here.

I go back into Scrivener and tell it to sync now, and it picks up the changed .txt file and pulls it in, but it still just has the three lines one on top of the other. I even tried creating a whole new document just in case I had somehow done some formatting magic in the others I was working in.

I can try a whole new project if that might help. Might as well. I hate bug reports with no real answer, but it really is the simplest case I can think of. Any suggestions you’d like me to try?

Hmm… perhaps user error here. Let me dig a little more, but for now call it pilot error and write me off. I’ll let you know once I figure out what’s going on. :slight_smile:

Never mind. Pilot error. It seems in my attempts to figure this issue out on my own, I inadvertently screwed up my default text style. So editing previous documents with content in them was sticking with the old formatting, while new documents I was testing with were getting the new, incorrect formatting.

Once I set my default text style back, things are importing just nicely. Thanks again for the prompt response and beta release. Sorry about that last part. :slight_smile:

Phew! Glad it’s working! :slight_smile: