Syncing with iTunes only

Hi everyone,

I don’t have Dropbox and my WiFi is very poor so I usually sync my iPad apps by plugging it into the computer and updating manually with iTunes. I’m having a problem doing this with Scrivener. I’ve managed to get my project from iTunes onto my iPad. I’ve now made some changes to the project and can’t figure out how to get it back from the iPad into ITunes. On the projects page my project is listed as ‘on my iPad’, something I can’t seem to change. The sync buttons say ‘update from iTunes’ but neither of these work when I press them. I’m probably being really stupid but can you help please? Thanks.

I’m afraid there aren’t a lot of people using this method, so forum users aren’t as familiar with this sync method. But I looked up how to share files with iphones/ipods using iTunes, and this guide might be relevant.

I think what happens is that you get a copy onto your iDevice, and then when that copy changes, you have to hook it up to iTunes and copy that new version back to your mac from the iTunes Sharing window. More general info on file sharing with iTunes here:

I’m not sure if there is anything more to it than that. Also take a look at the tutorial in Scrivener for iOS, in the file “Working with Projects” for the steps to copy a project back and forth using iTunes.

BTW, is it that your wifi is unreliable, or just slow? If it’s just slow, do note that once you do your initial Dropbox sync (after obtaining a free account), it only syncs the individual project files that change, reducing how much data has to be exchanged. With iTunes, you’ll have to keep copying the file back and forth manually.

I’m having a similar problem. I was able to get the project file to my iPad using iTunes, and edit it there with Scrivener. But when I try to bring it back, I still see the original version.

On the iPad, when I look in the Projects view, I see an updated modification time. On my computer, though, even after resyncing, I still see the original modficiation time. So I suspect that for some reason it isn’t finding the new version.

So I tried emailing it (in the Projects view, I selected the project, then clicked on “Send a copy”, and chose email). WHen I uncompressed the ZIP file on my computer, it still had the original version.

Which means I’m completely blocked. Suggestions?

The project modification time is not a reliable indicator of the last change to the project. To test whether the transfer worked, open it up in Scrivener and check to see whether your changes are included.


Are you checking the project date/time at the directory where you last saved the project on the Mac? If so, the date/time there wouldn’t have changed if you transferred the project to a different directory using iTunes. The same holds true if you’ve unwrapped the archive to a different directory. In either case, you’d have two versions of the same project at different saved states.

Thanks everybody for the responses. Sorry if my description was unclear. I am looking at new copies on my Mac (a copy using “Save to” from iTunes, another copy from unpacking the zip file). In both cases-the changes I made on the iPad don’t show up in Scrivener, and the modification time is the same as the original (although as Katherine points out that might be a red herring).

Coming at this another way, could you try exporting the project from the iPad, via the Edit button in the project screen, and copy the project to the Mac that way? It should be the same thing that iTunes is working with, but it will be a zip file instead of loose files and folders.

Thanks for the suggestion, AmberV … alas, when I unpack the Zip file, it still gives me the original version.

Are you sure that you’re transferring and inspecting the correct version of the file? iOS Scrivener can’t create a ZIP file containing an “old version of the project,” because the “old version” no longer exists after you made your changes. What you see in the iOS Project screen is all that there is.

(A simple way to test this is to experiment with a brand new project. It’s pretty easy to tell if a project went from 15 words to 30, or one document to two.)


I’m not sure what to say. I just tried again with the “send a copy” functionality, saved the zip file to a different directory on my computer, and verified that the zip file I’m unzipping is the correct one. When I open the newly-unzipped .scriv file it says that it’s a copy made of a project that was open at the time, warns that could lead to a collision, and asks if I want to make a copy. I tried both options (“Make a copy” and “continue” (without making a copy)) and in both cases the text I added on my iPad isn’t there.

I certainly hear what you’re saying about how it shouldn’t be possible for Scrivener on the iPad to be zipping up the old version. So, maybe that’s not what the specific problem is. In any case though I still can’t get my changes back to the computer.

Have you tested with a brand new project? – Katherine

Yes, I’ve tried with a new project. I also tried creating a new project on i the iPad, putting in a bunch of content, and when I copied it back to my computer using iTunes it was empty. I tried on another computer as well, with the same results. And I’ve tried on another iPad as well; also the same results.

Could this be a version mismatch problem? Both computers are running Scrivener 2.7; do we need a more recent version?

Yes. iOS Scrivener puts changes in a special Mobile folder within the project in order to facilitate conflict resolution. Scrivener 2.7 (or earlier) doesn’t know this folder exists and doesn’t look for it. You need 2.8.1 or newer.


Aha! I’ll give it a try …

Yes! That works! Thanks!