Synopsis font in full screen mode

The search function for the forum is frankly useless; I searched “synopsis font ‘full screen’” and it wouldn’t even prioritize posts with “full” and “screen” next to each other. I also tried searching the forums with a Google site-specific search but apparently they are marked to keep Google from indexing them, so I apologize if this has been brought up already.

I’m not sure whether to report this as a bug or a wish, but when I am in full screen mode and pull up the Inspector window to display my synopsis for the current scriv/document, if I want to add something to that synopsis it always inputs in the normal font of the editor rather than the normal font of the synopsis. For example, normally (not full screen mode) if I enter text in the synopsis area it is in Courier 12 or so, and appears that way whether being viewed in the full screen inspector window or the normal window. If I switch to full screen mode and go to the synopsis and start typing the new text appears in Optima 13 (and stays that way when viewed in normal mode).

I haven’t found anything which seems to govern this behavior in the preferences. I doubt this is intended behavior, and I don’t actually care about being able to change what font it’s in really, so it might be a bug. I just want it to stay the same font no matter where I’m typing the synopsis. But since I don’t have any error log or crash or anything to report I figured I’d post it here… please move this post if it is more suited to the bug forum. Thanks.

Hello,

I can’t reproduce this - the font in the synopsis area always appears in the regular synopsis font for me. Whereabouts are you typing the synopsis - in the “Inspector” panel that you can call up in full screen or in a QuickReference window?

Thanks,
Keith

I can think of a case where this can happen: if the corkboard has been set to use Small Font, and Small Font has been changed to effectively be the default in terms of its appearance, the QuickRef and full screen Inspector views will not alter the font to match, they always use the standard index card font (and I think that is okay—these views do not have the same size constraints that index cards do).

To verify if this is the case: Check you Corkboard preference pane in the Font section and see if “Small font” is what you are used to seeing. If it is, and you’d like everything to be uniform, then set your “Index cards text font” to be the same as “Small font” and then disable Small Font in one of the corkboards. Now everything should be using the same font.

I see why you can’t reproduce it. It only happens when I am editing my manuscript in full-screen with the Scrivenings (composite) view. When I’m editing just one scriv in full-screen it seems to come out in the synopsis font.

So to reproduce:

  1. Click “Manuscript” to show everything in there or it probably also works with a chapter folder.
  2. Select the Scrivenings view rather than Corkboard.
  3. Go to full-screen mode.
  4. Open the Inspector in full-screen and make sure it shows the Synopsis.
  5. Type something in the Synopsis view.

Alternately, when editing a scrv:

  1. Click View -> Go To -> Enclosing Group (or press ctrl+command+R).
  2. Follow steps 2 - 5 above.

The font that comes out is definitely the editor font, not the Corkboard small font or any other font set in the preferences pages.

Adding to this because I’m getting some extra specific results:

  1. The text bug in the synopsis field only happens in the synopsis for the containing folder/doc group–the synopsis for all the other items in the Scrivenings session are in the proper font.

  2. I only get the bug when there was no text in the container itself when I went into full screen. Adding text to it during full screen doesn’t prevent the bug, but exiting and then re-entering will stop the bug from happening again. Removing all the text from the container while in full screen, clicking in another document, returning to the container document and then typing in the synopsis will trigger the bug.

  3. The synopsis text switches to the proper font if I switch to another document in the Scrivenings session (while in full screen) and then back, but typing again in the synopsis will make that new text in the wrong (Editor) font, etc.

Great, thanks for the easy-to-follow reproduction instructions both of you, much appreciated. I’ve reproduced and (I hope) fixed the bug for 2.0.6. I had a piece of code checking the font for the main text area but had missed that it was being called by the inspector, too, and was therefore missing a conditional statement (i.e. “if this is the inspector don’t do use the main font…”).

Thanks again and all the best,
Keith

I know how that can be; I’m a software engineer by day. : )

Glad to hear it’s been found and fixed.

Thanks.

You’re right, I didn’t realize that. I had run across it when I was going to a new section and wanted to create a synopsis before writing it out. Didn’t consider that it might behave differently when editing a scriv which already had text in it. Thanks. Guess workaround for now if I want to edit the synopsis in full screen mode will be to put some dummy text in the doc until I finish messing with the synopsis.