System requirements for Scrivener 2

What will the Mac OS and processor requirements be for running Scrivener 2.0 when it is finally released?

I’m still running Mac OSX 10.4.11 on my PowerPC based PowerBook G4; will I be able to use Scriver 2.0? (I couldn’t find a more appropriate section to ask this question, although this is not really a support question.)

Scrivener 2.0 is planned to be fully Tiger compatible; same as 1.5x, and will be a universal binary. Tiger support is something under heavy testing and development right now.