Tab Key behaviour

Hello All

I just upgraded to Scrivener 2, and in general I am very happy.

I am however having an odd occurrence which I am sure is an easy fix, but I am lost:

When I hit tab inside a text window, it is taking me to the start of the next line instead of indenting my text.

Did I do something to my settings? Or do I need to configure this somewhere?


Check your ruler (cmd-R) - it sounds as though there is not a tab marker for the text to jump to, in which case it ends up going to the next line.
All the best,

Two questions answered thanks!

I did not know how to make the ruler show, which then showed me all my text was already tab indented.


I’ve been encountering this exact problem. I appreciate the explanation (and absolutely love the program), but I’m not sure what my next action should be.

I want to be able to tab forward as many times as I want. How do I enable the software to do that?

Thanks so much for the way you constantly tend this forum and help us use this fantastic software!


You will then need to add as many tab stops as you want. §14.4 (Pg. 133) in the help PDF.

I’m having the same problem. In the previous version, pressing Tab started the text about an inch into the page; with Scrivener 2 it starts a new line. I tried using the Ruler to set Tabs (see p.133) and also pressing Option+ but the problem here is that it does not set the Tabs permanently. It works fine on that particular card or even, strangely, on a couple but try creating a new one or jumping to a different folder and it resets to the default; i.e., starts a new line. Very much hoping this bug can be fixed soon. Otherwise, a seamless upgrade.

If you set the tabs in the Preference pane (Formatting) it will become the default for all new documents. Likewise, if you want it on a per-project basis, you can set it in the Project>Text Preferences pane.

Genius! I’d somehow set them in Scrivener 1 but couldn’t remember how to do it. I assumed it was a bug. Your reply sparked my recollection. Thanks again.

Note: If it’s not in there already, the moderators might want to add a note to the Manual.

Thanks, I’ve added a note to put in a short paragraph on formatting defaults in the basic writing chapter. This is of course all discussed in the manual already, extensively—but there is no cross reference to this discussion in the basic writing area.

Thank you. Very helpful. Can you erase a tab set if you set one accidentally?

Just grab it and drag it off the end of the ruler and it will disappear.

Having some new occurrences of strange Tab behavior. In certain cards the Tab settings simply do not work despite the Tabs being set as defaults in Preferences. Hitting Tab just makes it start a new line.

Further, adding tabs within the cards using the ruler does not work, either. It just deletes them as soon as I press return.

I’ve tried copying and pasting the text on one card into a fresh one but the same thing happened. Quitting and reopening the app does nothing. As I said, this does not happen with all the cards, just a few here and there. It’s a bit annoying because it’s so random. In fact, as I’m typing this it seems to be happening to more and more of the cards.

Could it be the default font I’m using or something similar (black, Courier, 18pt, regular)?

This seems to be a confirmed bug now, at least with me.

Any hints or fixes you can think of?

Now it’s getting even weirder. I left the desk for a couple of minutes, came back, clicked on a different folder, went back to one of the old cards, and now it’s working again. That’s great, but the Tab issue seems somewhat flaky.

Make sure you aren’t in script writing mode (check the footer bar and if you see hints about return/tab behaviour and such, then you are). This mode sets rulers dynamically, and so yes it would wipe out anything you add.


You seem to be speaking specifically about tabbing on index cards. That is relevant to the question.

Are you working on index cards in Corkboard view or in the Inspector? And, are you trying to tab in the title area of the card or the synopsis area (these are two separate field areas of the card)?


Hi Amber

I had a check. It’s in normal mode.

Hi Greg,

To clarify, I’m referring not to the lined index cards themselves on the corkboard, but to the notes ones writes on the “back” of them. (Not sure of the technical word for it; just where you take notes.)

Ah! The Notes area. I take you to be referring to the text area which is marked ‘Notes’ and which is in the Inspector area.*

Here are all the things I can think of that might run interference and are perhaps worth mentioning:

Setting/changing tab stops in the default paragraph setting in prefs will not change the tab stops of extant paragraphs. Moreover, if you go into a Notes area which has some text in it and click in there and hit Return, the new paragraph you make will inherit the paragraph setting of the paragraph you clicked into, rather than taking on the default paragraph style. Also note: If text you have in notes is the result of pasting from somewhere outside of Scrivener, it will not automatically have your default paragraph style.

Here is a thing to test: Take a case where it seems the default paragraphs have not stuck and your getting the tab-return behaviour. With your cursor on a troubled line, open the Format Bar, and choose Body off the paragraph Presets pop-up menu. This should turn the paragraph into your Default style. If the Ruler is open in the notes area you should see your tab stops appear on it.

In fact, try selecting all the text in some Note and doing the above and see if this completely obliterates the problem for that particular Note.

Fellow-Scrivener user

  • I’ve never encountered this metaphor whereby Notes represent the back of an index card. So, on the forum at least, I suspect saying ‘Notes’ will be better than saying ‘card’ for this area.