Tab Stops Not Sticky

Creating a tab stop only works for a single line. When I move to the next line, the tab stop disappears. How can I make these global and “sticky”?


The tab stops, like other paragraph formatting, will carry on to the next paragraph when typing, but when added after the fact will only apply to the selected paragraph (or, with no selection, the paragraph in which the insertion point rests). So if you’re cleaning up formatting on existing text, simply using Cmd-A to select all the text and then setting the tab stops will do what you need. You can also copy paragraph formatting from one paragraph to others using Format ▸ Paragraph ▸ Copy\Paste Paragraph Attributes (⌃⌘C and ⌃⌘V) or create and apply a paragraph style with the proper tab stops and other attributes, which would be a better long-term solution if this is special formatting you’re going to be needing to reuse somewhat regularly while you’re working in the project.

Tab stops are also part of the default formatting, so if you’re not creating a special paragraph format here but just need to reset to the defaults, ensure that the stops are set correctly in Scrivener’s Preferences in the Editing pane; then you can use Documents ▸ Convert ▸ Text to Default Formatting... on this and any other documents selected in the binder.

If it’s encoded in a style (add the tab stop and redefine the style), it carries over to other paragraphs of that style. If you press enter after the paragraph, the next paragraph has the same style if and only if you’ve defined the style with Next Style: set to the same style.

If you don’t want to use styles for this, you can use default formatting as mentioned by @MimeticMouton.

As for importing from Word, I abandoned it ten years ago. That’s not to say that you must abandon it as well, but there will always be complications involved if you don’t.

Sometimes Word is but an intermediate step; Scrivener allows only .txt, html (I think), .docx, doc, rtf?–but that’s about it. You can (that is, I remember) copying and pasting Markdown, I don’t think there’s a native filter.

I’m waiting on Scrivener themes, but until they come I find that I do a lot of initial drafts in Ulysses and getting formatted text out of Ulysses is a trip through css. Which doesn’t always work, as I found a few days ago when

.tab {
    tab-size: 2;
}

did nothing.

Mellel’s ToC feature is very easy to use but you can’t import Mellel files at all. Lists are a bane and a nightmare in every program except LaTeX, where even deep-nested lists are easy. So for print the path is often whatever=>Scrivener=>LaTeX.

Unfortunately, I often have to typeset legal documents and these can’t be changed, so in a list like:

1. Rule 1
2. Rule 2
4. Rule 3

the error must be preserved, which means you can’t use lists, though there is an easy --though non-automatic–fix in LaTeX.