Table of content after compilation [page numbers fall on next line]

Hi,
I have got problems with the table of content.

The page number is somewhere else but not in the line of the chapter.
How can I change this?

And there a some spaces between the chapters?
How can I delete that spaces?

I made a little video to demonstrate that: youtu.be/pIJl_1L7j14

Thank you and best regards,
Martin

The most common issue is a mismatch between the page size in Scrivener and the page size in the compiled document: the Table of Contents items won’t fit on a single line, and wrap to the next one. You can check this by enabling the Ruler in the Scrivener editor.

Katherine

Thank you Katherine,

Hmm…
If you take a look at the video above you will see that some chapters are very short, but I still get a word wrap between title and page.
I don’t get the word wraps only in lines with big titles. I get the word wrap in every line …

Thank you and best regards,
Martin

Yes. It’s not the length of the title, it’s that the ToC was created with one page width and compiled with another. Again, you can use the Ruler in the Editor view to check this.

Katherine

Dear Katherine,

sorry, but I am feeling a bit lost in all the options Scrivener is offering.
I am using a german version and I cannot find a “Ansicht Editor/ Editoransicht” (Editor view) in the help-tap to find that ruler.
Please be so kind to give me the path so that I can try it out.

Thank you.

Best regards,
Martin

View -> Text Editing -> Show Ruler.

For an 8.5" wide page (US Letter size) with 1" margins, there are only 6.5" left for text.

For a 210 mm wide page (A4 size) with 25 mm margins, there are only 160 mm available for text.

Katherine