Table of content looks weird

Im trying to learn scrivener.
I have been inserting af TOC like this:

But after closing scrivener and opening again it looks like this:

Have i done anything wrong?

That looks like the right-aligned tab stop for the page number tokens is missing, or has slipped off of the viewable area. Try turning off Page View mode and widening the window. Do they look fine if you do that? If so, there is nothing to worry about, that’s just what they’ll look like on a narrow column—though if you do intent to print at that size, you may want to move the tab stops over to the left a bit.

When i dont see it in pagemode it looks fine.
But when i compile it, it looks weird again

where do you think is weird

sony xperia z5 compact tasche

If you look at the two pictures.
The first one is how it should look. But it keeps changing to the last picture. Also when i compile it compile it so it looks like the last picture

Did you try AmberV’s suggestion of changing the tab stops to the left?

Do you mean like this?

It sounds like both your compile settings and your page view settings (which are often linked, so that makes sense) are too narrow for the right-aligned tab stop that page number tokens are set to. You need to move that tab stop so that it falls at a measurement that is within the printable area of the page.

[size=80]Line 1 has had the tab stop corrected.[/size]

I just used the non-fiction template.
But i will give it a try

It did not work…
Instead i manually inserted the whitespaces and then it works

But every time i update the TOB i have to do it again…
Every time i copy special TOB and inserts, it looks right. But after closing Scrivener and openen again it removes the whitespaces and it makes a break instead

Maybe it would be best to send a copy of the project to support then. It doesn’t sound like this is acting the way it normally would. Refer to this thread in the e-mail so that whoever gets it can forward it to me.