Table of Contents question

I’m trying to generate a .mobi file. All I want are the Chapter numbers (one, two, three…)

My binder looks like this:

Binder.png

Where I have the events of a couple of sections filled in as the title so I can find them again quickly.

In Compile > Formatting, ONLY the Level 1+ Folder has any kind of title attached to it (Chapter <$t>).

The ToC comes out looking like this:

ToC.png

Problems:

  1. The TOC lists “Chapter One 1” with no page number
  2. The TOC sometimes lists one of the scenes in a chapter – but only if the scene has a title in words. The ones with numbers it skips.

I have never had this kind of problem setting up a ToC before. Generally I get the “Chapter One” followed by the page number.

You probably have too many section breaks, from the look of it. Check in the Separators pane—you probably just want a section break on the “Text and folder” line. Also check in the Contents pane and scroll through the list, making sure “Page Break Before” isn’t checked off for anything (unless it specifically needs it of course). It looks more like Separators to me though, since only the first section of each chapter is printed in the ToC—maybe you have set files following folders to have a section break as well.

I’m not seeing that in the screenshot you posted. The numbered files are printing as well, this looks more procedural to me (section break at folder + section break after folder) than related to naming. Maybe it is not the screenshot you meant to upload? You mentioned it comes out as “Chapter One 1”, but I these characters split onto two different lines here—i.e. the “1” is coming from the text file in the Binder.

As for page numbers, I’m not sure what you are referring to. There are no page numbers in e-books. Perhaps you were testing PDF before and used the Edit/Copy Special/Copy Documents as ToC command? That will work for most things that have a fixed layout, but e-books change their “shape” according to the device and the reader’s preferences.

You were in the right area, wrong fix. :smiley: I had everything set to Section Break (except for a custom separator I have between text sections). Changing “Folder and Text Separator” TO “empty line” FROM “section break” completely fixed the problem. Thanks.

You’re right – I was doing .pdfs earlier today and had page numbers.