Table of Contents

I am using the Copy Special Table of Contents but unfortunately the formatting is completely off. Unable to understand how to resolve this. Please Help. The below images will show they actually look and how Scrivener is pasting them as table of contents .

Unfortunately it looks like one of your images didn’t come through, all we can see is the “before” shot.

But I suspect you might be running into a small bug we’ve recently been alerted to, where the “Page Width” paste setting is just ever so slightly too wide, causing the formatting to break in some compile settings.

You can get around that by changing the paste option to manual width, and setting it yourself. Points are 72 per inch, by the way, so you can multiple the text width by 72 to get the number you need. For example US Letter with 1" margins would have a 6.5" text block, so 468 points. If that doesn’t work, try one less, like 467 points.

Lastly, make sure your contents file is using either a dedicated “Table of Contents” Section Layout in compile settings, or if there isn’t one for the Format you are using, any layout that prints that it will retain the original formatting in the editor.