Table-related crash

Working on a table caused two crashes and in the second, some data loss.

The table originally had 4 columns across and about 70 rows. About 60 rows had been merged, one by one, into a single column across, as I completed work in another program. The width of the merged column was the same as that taken up previously by 4 columns.

I selected one of remaining rows that still had 4 columns. I marked all the row text with a colour and then merged the four cells into one cell. The single resultant column became narrowed to about 25% of the width of the whole table. (when I had done this before to other rows, this had not happened). Tried undo. Some odd behaviour, including jumping to head of that section. Tried redo. Scrivener closed unexpectedly.

I reopened Scrivener. The single column of the selected row was now the full width of the table and coloured. I tried to uncolour it (doing it had been an error). Scrivener closed unexpectedly.

I reopened Scrivener. All the rows of the table including and below where I had been working (about 60 rows) had lost their data. Some blank rows had become narrow single columns, others double columns.

The only thing I had done differently from before was colour the cells of the row before merging the cells – in the others I had merged first and then coloured the single remaining cell.

Not a major issue as I hadn’t done much work on the project today and the backup was fine.

Thanks, this sounds like a bug we have on the list to investigate, triggered by certain sequences of merging cells and colouring the text (odd as it sounds). I’m sorry it hit you, but glad to hear that you didn’t lose much work from it. I’d suggest using the Documents > Snapshot tool for your table document if you’re doing much manipulating of it that way; that may help to further limit loss if you do run into a crash again. (You can also just replace that one file from a project backup, so you don’t have to lose work on any other documents, but snapshots periodically while you’re working would potentially give you a still newer copy.) Make sure also that the document is saving periodically as you work. The last couple updates introduced a saving routine meant to better preserve your data in the open document in a crash of this sort and was tested with a different table crash that has been fixed; it’s possible the crash here is still getting around that, but just in case it was a matter of your autosave interval being too high, it’d be good to ensure that the project is saving frequently as well.

Hi Jennifer

Thanks for this. I’m doing a lot of table work at the moment and another oddity has emerged. In the table, which was originally set up with four columns, some rows have been merged into one column. Inserting a new row below an existing merged, single column row, within the table, brings up a four column row, but there is the ‘ghost’ of a further, fifth, column to the left, which I can’t get into. This whole row refuses to have its cells merged, either all together or two or three at a time. Selecting two cells sometimes highlights the cell on one side or the other as well. The only action one can take is to delete the row. Unfortunately, this means I can’t actually work with the table in Scrivener any more. I’m going to do the working on the tables in Word for the time being, and copy them back in for storage at the day’s end. Hope you fix it soon.