Table Uses Page Style Only?

Feature request - tables can use their own text formatting instead of using just a page’s formatting.

It is possible, though, to format after the fact.
Meaning: once there is content to format.

I have table-based character sheets that are obviously blank when I start a project, and in which I don’t necessarily want the same formatting for all the cells.
So what I did:
I’ve insert a space to each of my cells, then formatted it (the first line indent taking its presence into account).
So, the space character itself having been formatted to the formatting I want the cell to be, that cell is ready to be simply typed in.

I don’t know what your use case is, but perhaps that bit of info might help. (?)

The text is formatted how I like it in my editor (on the screen). But when I compile it to PDF, the text in the table reverts to what the page setting is using.

But I’ll try the space trick thing.

I see.
I never print my character sheets, so I wouldn’t know. I’ll take your word for it.
And what about styled text then?

From your description, the text is actually compiling as it would, even outside of a table…

No go. The changes look fine on my screen. Styles, etc. But on PDF are just page style settings. I might have a force over-ride page style checked on if Scrivener has just a thing. It has many such things. I will find out later.

And if you apply preserve formatting?

Where is that option hiding? I only see stitching options. I’m using Modern for my project format. Maybe tables are meant for Modern?

I am confused:
I went back to my computer, telling myself I’d try and find a way to make it work.

So I created a table, left side standard formatting (bold, italics, etc.), right side: styles.
This is what it compiled to:

It works. (?)

I probably have an over-ride turned on in the hidden depths. I’ll look in the manual. I’m using Section as the document type. And it’s in a folder type of Chapter.

Try a few other compile formats. (?)
If you can find one that renders the table’s content fine, at least you’ll know that whatever causes this is from within your compile format, and not elsewhere.

I tried it today. The tables were working fine with various fonts and styles in them. Yey! I went through each config setting in Scrivener and double-checked everything. Not sure which menu fixed things. I’ve updated Scrivener a few times this year without ever going through them.

A glitch, maybe. (?)
It’s good if it now works.