Tables and wrapping problem

Apologies if this duplicates an answered query - I have searched the forums and the help files to no avail…

I’ve set up separate documents containing duplicate tables to organise my notes so I have a constant format for info from my references. My problem is with the way the text in the tables is displayed…

… in some cells, all the text in the cell that comes after a carriage return (in that cell) seems to be wrapped to a much narrower spec than the text before the carriage return. (I’ve tried to attach a screen shot to this message to show what I mean). I’ve tried fiddling with margins / paragraph formatting etc to no avail, but here’s the wierd thing… as soon as I switch to full screen mode, the wrapping sorts itself out fill the available space in those cells.

It doesn’t do it with all cells, and the difference seems to be proportional: if I make the window narrower, the oddly-wrapped text gets narrower too, yet still not filling the cell…

Why is this? And can I change it so that all the text in all the cells conforms to the cell boundaries instead of making a narrow collumn of text after a line-break?

Am I being a numpty (probably)? Any advice would be gratefuly received!

I’m using v. 1.03, and I checked the changes to the latest beta version and there was no reference to this problem… should I upgrade anyway or stay put until the official release?


Unfortunately, the tables in Scrivener are rather horrible to use and very buggy. My only defence is that I didn’t program them - Apple did! Scrivener uses the standard OS X text system, which is showcased in TextEdit. This means that Scrivener has all the power of the OS X text system without my having to code a whole rich text formatting system of my own (which would take years), but unfortunately it also means that Scrivener also inherits the flaws of that system.

Try copying and pasting the tables into TextEdit and see if you see the same effect. I am guessing that you will.

Sorry, I know that doesn’t help you an awful lot, but unfortunately tables are a little out of my hand. Feel free to shout at Apple about them (complain about the poor implementation of tables in TextEdit at - the more people who do it, maybe they might listen :slight_smile: ).

All the best,

Thanks for such a swift reply Keith :slight_smile:

I tried copying it to text edit, and it did behave the same. I also tried creating a table in new text edit file, and it did the same. Pants! :frowning:

I think I’ll just ditch the tables altogether and use headings instead for a consistent format, otherwise that’ll niggle me relentlessly.

By the way, thanks for creating such a superb program - starting my thesis is now half as scary as it was before I found Scrivener. And it’s also tempting me to return to scribbling out fiction in my spare time purely for pleasure. Wonderful!

Sarah :smiley: