Tabs/Indents change when Inspector open/closed

Dear Everyone,

This is my first post, so first, a thank you. This forum has been tremendously helpful.

Second, a question: When the Inspector is closed, my documents look properly formatted. The indents are where I want them, and the lines go all the way to the right tab at 7.5". Things look the way they should be. But when I open the Inspector, my line breaks and indents look all screwy. This is quite distracting because I cannot view things how they should be with the Inspector open. This has led me to waste time by continually fixing the layout every time I switch between a full editor pane and the editor along with the Inspector. I would like for the document to look the same, just within the narrower editor pane, when I have the Inspector open and closed. The two screenshots below show how it looks when open vs. closed.

I would greatly appreciate some help in figuring out how to sort out this. Thanks everyone.

Best,
jg

Perhaps the Page View mode would be better for you? The only way to really solve this problem is to fix the width of the editor, which means horizontal scrolling if it becomes to narrow. The way Scrivener is designed, you don’t normally have to worry about this since the editor will collapse down to a small size if necessary, no scrolling required. But if you do want it to follow a more paper-sized approach, View/Page View/Show Page View should do the trick.

Hi Amber,

Thanks for your prompt response. But, Page View mode is not what I’m after. I’ll try to re-explain because I don’t think I was clear. So, when I have the Inspector open, in this first screen shot, the line breaks are incorrect.

It doesn’t make sense to me why, for instance, in the third line “Norton, 1971. Print” is not on the second line right after “York”. They should be in the same line, and “York” should be a hanging indent. It should look like this:

Abrams, M.H. Natural Supernaturalism: Tradition and Revolution in Romantic Literature. New York:
Norton, 1971. Print.

This is correct, how it looks when the Inspector is closed. Screenshot:

Switching to page view doesn’t do anything about this. I think it might be something to do with the tabs or hitting enter at the end of lines (which I had to do to correct the muckup when Inspector is open/closed)? I can’t think of what else to do in this case. I’ve spent a ton of time going back and forth fixing this kind of thing on many of the individual documents in the project.

Best,
jg

Are you basically just going for a hanging indent? Because if so, using the indenting features will be superior than tabs and returns for that.


I have turned invisible characters on Format/Options/Show Invisibles so you can see the actual characters I’m using here. The indent itself is handled by the left block indent control. I’m typing in nothing to get that effect. When the line wraps naturally because of the window width (or margins on paper), the continuation wraps 1.2cm in. Likewise, when I hit Ctrl-Return to create a line break (not paragraph break), the second line of this paragraph, starting with “Norton” indents as well.

Sorry if I’m still off the mark!

Seems to me, the problem is the right margin. I’m assuming the editor width is set to “Automatic” and the window width is showing it how you think it should be while the inspector is closed. When you open the inspector, the editor is shrunk to allow space for the inspector, so the automatic margin width is being shrunk, and text which formerly fitted over one line is now wrapping and the end of that line is now wrapped to the right margin. Putting in line breaks and returns manually to make it appear right is only compounding the problem.

Set an appropriate hanging indent and set an appropriate editor fixed width if you can’t increase the width of your window when you have the inspector open, and only put a carriage return at the end of each bibliographic item. Either that, or, if you are already using the maximum window width for your monitor, set up two layouts with appropriate editor/margin widths, one with and one without the inspector and toggle between them, rather than opening and closing the inspector.

My ½pworth.

Mr X

Hi Amber and Mr. X,

I do have the hanging indent tab set, so I don’t think that is the issue. But I will fiddle with the automatic right margin width and fixed editor width to see if that solves it. Also, I wonder if there is a problem with setting the text to wrap with hyphenation vs. not wrapping. I’ll play around with these options and let you both know how it goes.

Thanks so much!

-jg

In nearly all cases you don’t want to have a right indent set, and when you do, you have to make sure the math is right considering that our ruler isn’t a page ruler, but starts at 0" at the text block rather than the paper edge. The typical measurements you might be familiar with probably aren’t valid, since once they are put into a page with margins, the ruler will be pushed over by the width of the left margin. So in your case, you’re setting up a 7.5" right indent, but when this page gets put into margins, that could end up being 8.5", and make a mess in Word as the text will be flowing off the paper.

Just wanted to make sure you were clear on the purpose of that tool. Some people coming from word processors think the right-indent needs to always be used, more like one might set a margin, but here it really isn’t. The only time you should need it is when you are intentionally pushing text in from the standard margin.

What you typically want, in normal text, is to push the right indent all the way to the right so that the text wraps with the window width. If you add an Inspector at that point, it just compacts down further. It works more like “draft mode” in some word processors (Word, for some reason, still wraps to the margin width in draft mode).

Basically: get used to the idea that in Scrivener you’re assembling text, and not so much worrying about precisely which word the line wraps on, because odds are it is not going to look the same when you compile and open it in Word, anyway—especially not with an 8.5" indent. :slight_smile:

The hyphenation setting is just for your comfort. If you like the way it looks then use it. It isn’t something that will export.

By the way, here is how I handle the Inspector. Not quite for the same reasons you do, but I do like what I’m reading to stay put and not suddenly shift to a different wrapping solution because I opened the Inspector:


These settings are in the Editor preference pane, middle-right.

Hi again Amber,

I think you’ve sorted out the issue, though your 534 pixels fixed-width is too narrow for the editor pane on my screen. It looks like this:

I played with this a bit, but then just entered zero to force the window to fit the screen. Should I now get rid of the right margin I set? My last question on this is, can I make this change global for all the documents in the project that have the messed up margins? Can it be done retroactively?

Thank you so much.

-JG

Sure, the precise width will be down to taste. I write with 12pt and 100% zoom, so a relatively narrow text column is best for me. The main point was that I leave a “gutter” area to the right of this column (however wide it may be) where the Inspector can freely come and go.

Yes, as it is too wide anyway at the moment, but you don’t need it for your particular usage anyway. Just select all text on the page and drag the right-indent marker all the way to the right of the ruler.

There is a tool, Documents/Convert/Formatting to Default Text Style, which can be used to clean up formatting to a specific default (set in the Formatting preference pane). I’m not sure if that is the best tool for you, since you have mixed formatting here like hanging indents—and clearing the right indent will also clear those. It might be easiest to just fix the right-indent as a part of a selection, as described above.

Note you can take a Snapshot (Cmd-5) before experimenting with the more broad-spectrum tools.

Another approach that many prefer is to let the compiler clean up text. Then you aren’t having to worry so much about formatting while writing. However that is going to have similar restrictions in that it works better for text that is all meant to look the same. Unless your entire project has hanging indents, it’s probably not the best tool for you. But if you are interested in that, it’s the Formatting pane in the compile settings. You can completely redo the look of a document from there.

You should also turn on Format/Options/Show Invisibles and clear out any manual carriage returns and tabs you added.