Taking snapshots of multiple files

I thought I understood how to accomplish this, but for some reason, it’s not working as I expect. Here’s what I just did:

I have two documents in the binder without any previous snapshots. I selected them both, which switched the right-most editor into Scrivenings mode. Then I clicked the Snapshots With Titles toolbar icon. Only the first document in the selection got a snapshot.

What am I doing wrong here?

Mavericks 10.9 (.0?)
Scrivener 2.5

The only thing I can think of that might be the case is if you’re switching focus to the Scrivenings session. So long as the selection is active on multiple objects in a group view or in the Binder, it should be titling them both at once. I’ve tried from the toolbar, menu, and with the shortcut all with the same expected result.

I think you figure out where things went wrong…

Oh wait. You aren’t Vic-k. You’re good with thinking.

… ish. :confused: Especially when I’m writing fiction. Seems to put other parts of my brain into sleep mode.

One thing I wondered about in an previous attempt to take multiple snapshots at once was if I selected documents in the binder, do they have to have been loaded into an editor (in any mode)? I have both editors locked most of the time while writing sequentially, and I had thought that my issue stemmed from those selections not being reflected in an editor. Now I’m not so sure what the issue is, other than my decision to “upgrade” to Mavericks. I should have followed my own advice and waited for at least one point release.

No, it just takes the item list from the current selection. It doesn’t matter what the editors are showing. Though granted if you are “fact checking” with the Inspector those may not be showing the same things as what you have selected in the Binder—but I’m sure you’re just looking at the dog-ear icons.

Well, I’m stumped. I’d give the usual run-about with basic troubleshooting. Blank project test, preferences wipe and re-install.

If it makes you feel any worse, I’m testing on 10.9 as well. :wink:

Oh, shouldn’t make a difference, but MAS version?

I’m stumped too. I tried with a fresh project, and everything that I tried worked, dammit! :stuck_out_tongue: And yeah, the dog-eared (or not dog-eared) corners were my first clue that the last multi-select snapshot didn’t work.

I’m using the direct download version of Scrivener.

SCRATCH THAT! I’ve got it figured.

Go into full screen mode. Hide the binder. Have it set to slide in when you move the mouse to the left edge. Make your multiple selections, use toolbar icon to make titled snapshots. Only one of the selected documents will get a snapshot. I checked the icons and the inspector panes for each document, but only one had a snapshot that the UI would reveal.

… And a quick check of the .scriv file bundle shows that only 1 snapshot was created.

I’ve almost got it, but it’s probably close enough, because in my case when I tried that I got no snapshots. It looks like the full screen slide-out toolbar thing is stealing focus from the Binder. Maybe that could be solved by capturing the selected IDs before presenting the titling interface, instead of on clicking Okay—assuming that is what the case is.

Odd. One thing I just tried is to snapshot two documents selected in the binder in full screen mode, but I used the menu item instead of the toolbar icon. Same result; one of them got the snapshot, the other didn’t.

It must be a problem with the slide-out binder in general then, though it is strange that at least one file remains “marked” as the panel slides out of view. If there is a problem with getting an active selection out of the now-off-screen-binder, you’d think the result would always be like the one I get: no snapshots. Well, hopefully this is all enough evidence for Keith to go on, even if the particulars are different.