Target box suddenly wider than my screen

Sometime between using Scrivener yesterday and today, clicking the Project Targets icon results in a pop-up box that is the normal height, but nearly twice as wide as my screen (I have to drag and move the box to see the whole thing). Now, I was using the trial version until Jan 28th, when I purchased the full version, and then was notified of an update which I downloaded and applied.

I do not reboot my computer very often. It’s a bad habit from the old days of Windows when it would take five to ten minutes to reboot. I leave it running pretty much 24/7. However, yesterday we had a power outage, and my computer was rebooted. This is the only reason I can think of for the change between using the software yesterday, and using it today.

The program was NOT open when I lost power, so I don’t think anything was corrupted that way. I am hoping someone can tell me how to fix this, as I use the Project Target feature quite often, spot-checking as I go.

I’m perfectly comfortable editing text config files or digging in the registry.

Small update, it seems the popup box for importing web pages is also popping up enlarged. I’m attaching a screen shot.

Also thought I’d better add version number and my operating system info. Let me know what else you need.

Scrivener version:
Windows 7 64-bit

Hi Tilandra,

This is definitely a weird one. I’ve had two other users report the same problem with the compile dialog suddenly appearing several times the screen width, and in both cases the issue seemed to rather miraculously resolve itself, so I’m afraid I don’t yet know either what triggers the bug or what precise steps resolve it. Based on the previous cases, I’d try first just doing a complete uninstall, manually deleting the Scrivener installation folder if it remains following the uninstall, and then downloading the 1.2.5 installer from our website (here’s a direct link) and installing that.

Before you do, though, could you check and let me know whether this problem persists through all your projects or if it is specific to a particular one? For instance if you close the current project and create a new blank project (you may need to adjust your settings in the Genera tab of Tools > Options to have the New Project window appear when no projects are open so that you can perform the actions in this order), does the Project Targets dialog or web import dialog open at the usual width?

If it is specific to a project, would you be willing to send it as a sample to AT literatureandlatte DOT com? Just choose File > Back Up > Back Up To… and back it up as a ZIP somewhere convenient so you can send that as an attachment.

Also, are you using a multi-monitor set up or do you have any software installed for managing program windows or such (e.g. I know another user had UltraMon installed for working with two monitors)?

I’d really like to get to the bottom of this so we can fix the bug, so I appreciate all the details you can provide!

Another project started before purchasing and installing the update has the problem. I just started a new blank short-story from the new project wizard and it also has the enlarged dialogue.

Doesn’t seem to be project specific then. I’ll try the uninstall/reinstall route, and let you know the results. Kinda didn’t want to have to go that far. :smiley:

Reinstalling did not fix the problem.

I noticed upon reinstall that I did not have to re-initialize my license with the serial number. Is this a function of the installer you linked to, or did I miss a file I was supposed to delete? I uninstalled through the Windows Programs and Features panel, then deleted the Scrivener folder on my C: drive. Rebooted. Reinstalled from the 1.2.5 installer you provided in the link.

As per your other question, I am running Catalyst for my video card (ATI Radeon HD 5700 Series). It has a multi-monitor feature, but I am only using one monitor. Interestingly, Catalyst prompted me for an update when I rebooted from reinstalling Scrivener. I rebooted one more time after updating Catalyst, just to be on the safe side, but the problem persists.

So now I’m stumped.

When the dialog box pops up, the left edge of it seems to be where it normally would pop up if the thing were working normally, but the right edge of the box has decided to go nuts and run off to Tahiti. Something in the code that defines the right boundary is getting bonzo information?

Sorry… spit-balling hoping something will set off a light-bulb.

Thought I’d add my dxdiag file in case it has something useful for this problem.

DxDiag.txt (46.6 KB)

Thanks for checking on the other projects and the additional diagnostics. I’ve forwarded that on to the developer, along with the other details, as I’m a bit stumped myself at this point. If it were project-specific we could try clearing out the settings for that project, but it seems unlikely to make a difference given that you’re experiencing the same issue on completely new projects.

I did find a similar report with other Qt software when I hunted this up on Google, the idea being that an overly long path had been stored incorrectly and was causing the dialog to open too wide in the following instance. Do you recall what changes you made to the project between when the Project Targets opened normally and when it opened too wide? (I know, that’s a rather broad question!) Specifically I’m thinking of things like changing document titles, importing, exporting, or compiling, creating links or linked external references, or any changes made to the project’s .scriv folder itself (changing its filepath or such).

Is there any easy way to temporarily disable Catalyst so you can reboot and try running Scrivener without that in the background? I don’t really expect it to make a difference, but it’s worth testing just to definitely eliminate it.

Not knowing any other way to keep Catalyst from booting, I used the system configuration utility to tick off both “Boot in Diagnostic Mode” on the “General” tab, and “Safe Boot” on the “Boot” tab. (In Win7, click the start button and type “sys” into the search box, and the SysConfig utility should pop right up in the search list, for any other users trying to dig into the problem).

When I rebooted in Safe Mode and started Scrivener, the Target box was back to normal! Of course, Safe Mode keeps a whole slew of things from loading on start up, so I’m not sure that’s going to help you narrow anything down.

Coming back from Safe Mode and booting up normally again, the problem is back.

Next thing I did was go back into the SysConfig utility, and use the “Startup” tab to deselect ONLY Catalyst, so it was the only thing that was removed from a normal startup. Reboot. The problem is still there with Catalyst alone disabled.

I could go through and turn each process on and off before rebooting, but honestly that will take forever without a list of probable suspects from you folks. :smiley: What should I try next?

Edited to add:
I forgot to address the second paragraph of your post. I have a terrible memory when it comes to sequences of events. I did change my backup folder from the default location to a different hard drive, but I’m not certain if this was before or after the problem started. The file path it’s in now is: E:\My Documents\My Writing\Scrivener Backups I’m not sure that’s an excessively long file path, but it does have spaces in the folder names and I know I’ve run into problems with those on other programs, but usually related to the program finding the darn thing, but my backups are being created as expected. Anyway, hopefully somewhere in all this we’ve got it narrowed.

Thanks for testing this! Spaces shouldn’t normally be a problem, but obviously if it’s a bug, who knows. :wink: I appreciate your giving it a run in diagnostic mode. Next step would be to do a selective startup, deselecting “Load startup items” (but leave services running). If that fixes the problem, we’ll at least have narrowed it down to a conflict with other software running at startup, and then we can go through that list. This is moot of course if you have nothing at all listed in the Startup tab of msconfig; if you have a lot, I’d start testing by using a normal boot but disabling ones in the Startup tab that you added recently or were recently updated, and working in batches–if it works all right with the first half enabled, you can add in half of the remainder, etc. Unfortunately I can’t give you further specifics since we don’t know of any compatibility issues with software causing this, but we may be able to make some guesses based on the list of what you have running.

If the problem still occurs with the startup items disabled, so that all you’re running is the OS and system services, then we’ll take a look at those.

The possible reason for your troubles might still be the power loss, Tilandra. The power loss might have corrupted some System Font information that is used to calculate the default size of the dialogs. There is nothing for me to prove it, but sounds like the only reasonable explanation based on your posts.
If you use the latest Beta 1.5.1.X, one trick I can think of is setting a Custom GUI Font. Use Tools->Options->Appearance->Fonts->General->Menus & Windows. You might also experiment and restart Scrivener after this modification.
As a final resort I would also suggest to retry uninstalling and installing Scrivener again. You mentioned that you did not have to license Scrivener again, which makes me think that the Uninstaller did not remove everything. After uninstall please verify that the registry key: “HKEY_CURRENT_USER\Software\Scrivener” is also deleted. Use '‘regedit’ to navigate and delete the registry key. I would expect you to register Scrivener again with your license after the new install of Scrivener.
Let us know, whether some of my hints worked.

Thanks, Tiho!

Tilandra–Do what Tiho suggested first, since he’s a developer and knows better what he’s talking about. :wink:

I have to apologize. At one point, I got so frustrated with my computer, I broke down and repaired Windows 7 by reinstalling, using the advanced recovery tools. I am now currently reinstalling my applications. So I’ve probably set back your troubleshooting of this bug. No matter what I did upon uninstalling and reinstalling Scrivener, it was NOT asking me to re-apply my serial number. I looked for the registry key in the place Tiho listed, and it was not there, so I thought I had a clean uninstall. Upon re-install, however, it still did not ask me to register. And I was having other random problems with my PC. When I get that frustrated, I have a tendency to throw up my hands and clean my boot drive and start over. So I did.

However, Scriv is now working as intended.

I reinstalled Scrivener first, and am now running I am now slowly reinstalling my applications, and applying Windows updates, checking Scriv as I go. If it breaks again, I’ll be able to tell you which application or driver did it. If it doesn’t, we’ll have to assume that the power outage corrupted a crucial file, I guess. Sorry about giving up, but if I let myself get mired down in fiddling with my operating system, I do nothing but that, and then I’m not writing. Which is not good. :smiley:

I’ll let you know if this problem pops up again. I’m hoping not.