Text>Convert>Multiple Spaces to Space

Hello Keith,
hello y’all,

If you don’t mind you might check the following procedure in Scrivener - but please do it on a copy of a project:

  1. make sure there’s at least one double space somewhere in a text,
  2. select that part of the text, move down the cursor (still pressing the mouse button) to the bottom of the window to make the text scroll and get a selection that exceeds the text that’s shown in the window,
  3. use the menu command ›Text>Convert>Multiple Spaces to Space‹.
    Having done this you might find that some of your text is not visible anymore.
    That’s what happened to me actually. I was able to ›recall‹ the unvisible text by selecting another document in the binder and then reselecting the one I worked on. But now in this document any keyboard input seemed to be blocked. I say ›seemed‹ because if I gave Scrivener the two seconds to save the project or did a ›Force Save‹, then closed and reopened it, I saw the text was changed by my keyboard strokes even thought I couldn’t see the changes when I made them. The first time this happened to me working on an original draft I was very happy to be able to reconstruct the text from a recent backup.

Of course I don’t know if all this is happening on your machines too. It is reproducible on mine (iBook G4, 933 MHz, 640 MB RAM, 10.4.8) in about 5 of 10 tries. As this might be a graphical issue I should mention that I’ve set the main editor in Scrivener to a 125% zoom level.

But let me emphasize this is the one and only issue that kind of irritated me when working with Scriv so far. It can easily be avoided by using the Find and Replace option when hunting for unwanted double spaces – and in no way it is darkening the bright light of this admirable v.1.0 release!

K.