text copied from .doc won't wrap in editor window


Just starting in Trial mode - and falling in love with this, but …

I’m experimenting with getting my book into Scrivener from a Word .doc file. Started by dropping it into Research section and then copying sections from that. (Haven’t experimented with smarter import options) . Text doesn’t wrap in the editor window. Same thing happens if I copy text directly from the original document.

I’ve read a couple of refs to this type of problem on this forum but couldn’t see an answer. Haven’t looked into compile as the text is uneditable due to long long text lines.

When I copied the text over it had 3 formats: Heading 1 Times, Normal Times and Normal Times Italic. No indents.

I don’t see a wrap button on the toolbar (that was mentioned in one post) and it is not an option in customizing toolbar. Also I dragged ruler thing to edge but no effect.

So hopefully this is a simple fix!


Sorry you’ve run into a problem! If you select the document in the binder and choose Documents > Convert > Formatting to Default Text Style, does that make any change to the ruler?

You also mentioned dragging the right indent marker on the ruler. The ruler works per-paragraph (as in Word and such), so just to double-check this, try selecting the text in the editor first, then dragging the right-indent marker to the left first, to set a right indent and see if that has any effect. If it does, try then dragging it all the way right to erase it (setting the right indent, and thus text wrap, to the right margin), with the text still selected.

The problem is most likely the heading style from the Word document, so if the above doesn’t fix it, you can probably get around this for now by saving a copy of your original document and then stripping the styles in it (just set everything to Normal) before importing that into Scrivener.

Assuming that you did import the file initially (I think you dragged it from Windows Explorer or such into the Research section of the binder, right?), could you go into Tools > Options… and click the Import/Export tab and verify that you haven’t enabled the option to use Word’s importers/exporters? You could try ticking that, restarting Scrivener, and then importing again to see if that helps also.

Thank you for your concern; however, I am already so impressed by this program that I entertain the notion that this is intrinsically a small, pedestrian problem - something to be dusted away.
(Say, writing on a writers’ forum does inspire somewhat grandiloquent phrasing!)

My text has 2 formats (italic and normal); oddly, they are quite critical. As I understand it, from trying this earlier, this procedure will strip my (wonderful) text of it’s ‘critical’ formatting! Not good!

Hmmm, I’ve re-installed this program on an antiquated laptop computer - to continue testing, and … it has installed with no ruler showing! So, does Scrivener adjust what it installs based on the ‘grunt’ of the computer? Or have I somehow switched it on in the previous install (on a much more robust computer)?

Shall attempt “ruler” recovery - like a tale from yore. (back) Success. But after selecting all the text and then dragging the upward oriented arrow on the right of the ruler to the edge of my laptop, nothing changes - word unwrap persists!

I’ve moved all that I can on the ruler (with text selected) left and right, and found no discernible effect; although I can make the text disappear off to the right of the screen. In trying this I seem to have created new markers on the ruler - feeling like a loser now - yet nothing has changed. Double-clicking anything and then moving it has had no useful effect.

Reread your post about ‘choose Documents > Convert > Formatting to Default Text Style’ to check if I had missed something. The options that appear when I do this are not what I want to have happen to my text. I have italic followed by normal continuously repeating and the options offered, at face value, would change this (or do nothing); as I read it. So I can’t see how this helps with my particular problem.

I can’t really adopt your next suggestion,

as the formatting (style) is critical for the document to make sense.

Did this. Switched it on and off and copied and pasted the same text - no change.

I’m fretting now; just how stable is Scrivener for Windows? (Just kidding, I’m still brimming with confidence, just let me get another beer.)

Thank you for your suggestions. But … still persists.

My source doc is from an old version of Word (XP) not likely to be too difficult to wrangle, but no luck so far in converting.

Okay. Any other ideas, anyone?


PS I want Scrivener to work so bad … well actually no, I want it to work superbly. Can it?

Have you tried exporting from Word to .rtf format and importing that? Would that help?

I’m on Mac, so I don’t know what your Windows ruler looks like … the ruler, if invisible, should only be a mouse-click on a menu or a keyboard shortcut away. On the Mac the right margin is a leftward pointing triangle, not an upward pointing arrow. It sounds to me that by clicking in the ruler, the extra symbols you see there will just be tab-stops of some kind that you’ve added, so no real need to worry about.

There have been other posts about right-margin issues in importing from Word, so you might trawl through the forum — or use the search facility to find them.

On the Mac version, when you choose it brings up a dialog box, and I believe if you tick “Convert font only” it doesn’t strip italics, but I’m not sure. Try that on a copy of your project, to be on the safe side.

Good luck …


Okay, got it. But first …

Saving in rtf and then adding it to Scrivener as a file under Research doesn’t work.

In Word I switched on ‘Show all Formatting marks’ and noticed that Word adds some sort of additional mark for paragraphs that use ‘Styles’ - all of my book uses Styles so I can quickly change fonts to get the right look etc.

I tried saving as html and then filtered html (Word save option) but when imported into Scrivener all quote marks came in as white colored question marks on a black diamond shape! Trying to replace these with ordinary quotation marks in Scrivener didn’t work.


However, if I save my Word version as rtf, open it in Wordpad, save as … OpenDocument text (Wordpad save option), close Wordpad, re-open the saved document in Wordpad (or Open Office), copy the text and paste it into a Scrivener empty text file … it works.

I think this process strips away the Word style marker yet preserves the font state.
Note that if the document is not re-opened in Wordpad then copying the text does not work - presumably the style marker is still present.

Crazy work-around but it works. Done and dusted!

Thanks MimeticMouton and xiamenese for input on trying to solve this.


Glad you found a solution, and thank you for sharing the details.

For future reference, Documents > Convert > Formatting to Default Text Style always preserves character formatting like italic, bold, and text color, so you don’t need to worry about that; sorry I wasn’t clear! (That’s true for both Mac and Windows; you don’t need to tick any options for it.) So that may still be worth trying if you get this again.