Text cut off at right edge of main editor.

I’m on Windows 10 with the published version (64)

I have Options>Main Editor> Appearance> Default Editor Width set at 350 points. I’ve checked “use fixed width editor” and “center the editor when using a fixed width”, and I’ve set all the editor margins at 10 points.

When I’m working in the editor the last character or three in the long lines are missing–in the sense that I can’t see them.

If I move the cursor to the right it moves the right number of times before jumping to the next line, but the characters themselves are invisible.

I’ve tried changing the zoom from 100% to both less and more, without any improvement. I’ve also tried changing the editor margins, but this also has no effect.

Kind of a bummer when proofreading.

I’d turn off fixed-width entirely. Scrivener isn’t intended for WYSIWYG editing anyway.

If proofreading in Scrivener doesn’t work for you, do it in a PDF or docx.

I’m aware of this display bug when in Scrivenings mode (unrelated to fixed-width editor); if it is the same issue, you should be able to find a sweet spot of right/left margin padding and editor zoom level that will ensure the full text is displayed, though I understand you’ve already been fiddling with that.

If you are seeing this even when viewing only a single document, is there a difference depending on the amount of text in the editor, determining whether or not the vertical scrollbar displays?

I opened the same project this morning, and it was absolutely fine. I can’t make it repeat, so I guess this is a one-off.

I’m having this problem currently in Scrivenings mode, Windows 10. Currently using Sitka Text as main font. I’m attaching two images to show the problem. The first shows the problem, with parts of final letters and punctuation obscured for this sample, and the second shows a slight expansion of the margin to reveal what was under the scroll bar without changing the line wrap. This seems to be related to a difference in the width of the (wider) scroll bar and the width of the right margin relative to the total editor space. You can see this difference at the top. The wider scroll bar covers some of the text.

Screenshot - 3_10_2022 , 6_06_08 PM
Screenshot - 3_10_2022 , 6_05_32 PM

This happens with or without setting fixed width. If fixed width, and the scroll bar is not set next to text, there is a white space in place of the scroll bar that also blocks visual for the text. Here’s another screen show to illustrate:

Screenshot - 3_10_2022 , 6_10_26 PM

Interestingly, this does not happen in single document mode, only in Scrivenings mode. Here is an image with fixed width, centered, with scroll bar next to text, showing a clear difference. In single document mode, the scroll bar is placed outside the margin indicated by the ruler, whereas in Scrivenings mode, the scroll bar is placed inside the editing space itself.

Screenshot - 3_10_2022 , 6_17_15 PM

Trying different fonts, some are worse than others, but all share the problem.

Finally, fiddling around with the Formatting settings, using fixed width editor and setting the right margin a quarter inch smaller seems to fix it for now, at least if I’m only editing in a single editor window. If I open the other editor, the windows must narrow to fit, and I’m back where I started unless I force the fixed width to be the same or smaller as the width of the dual editor window. I’m also concerned about going back and forth between desktop and laptop because of the different monitor sizes, and about compiling down the line, so I would really prefer not to have to set a fixed margin in Formatting settings.

Really hoping this is something that can be corrected.

Increase the margin to at least 40.

Thanks for such a quick reply @Vincent_Vincent. I’m looking to find how to do what you’re suggesting. Is there a right margin setting for the editor that is different from the Formatting window? Or is there something there I’m just not seeing?

InkedInked2022-03-10 21_51_47-Window_LI

1 Like

Oh, my gosh. I’m rolling my eyes at my blindness. Thank you so much!!! Problem solved! Really appreciate it.

1 Like

Thank you Vincent_Vincent! I started having the problem again, after posting here, but by that time had given up on a solution, so I was just living with it. When this showed up in my inbox, it took me about three seconds to fix it!

1 Like