Text formatting in lists

I’ve set the default font to be Optima 13 Regular, but when I am doing lists, any item that comes in with a “-” character for the bullet, ends up in Lucinda Regular 14. I’ve set up styles to correct the font back to the default, but this is a hassle for every bullet point in the list. I have traced the problem to the “-” character used for the bullet. The hyphen bullet character is itself in Lucinda Regular 14, which appears to reset the font for the whole line to Lucinda Regular 14. Is there any way that I can change the formatting of that bullet (or any bullet for that matter) to match the default style for the page/document?

The only reason that should happen is if you are clicking right next to the bullet and then typing from there, rather than clicking out in the white-space to the right and typing from the “indent” off of the bullet. The text system should be setting your font back to what it was before, for the rest of the line. Only the hyphen gets printed in another font (and it does that because it isn’t actually a hyphen, but the Unicode “Hyphen Bullet” character, which is thicker than a standard hyphen). But, if you really want the hyphen to be the same font, then you could use “Custom” and type a hyphen into the “Prefix” field, instead of using the built-in hyphen bullet.

This is how it works in the English system region setting anyway. Perhaps, if you are using another language there is a bug with that language?

If I am writing a bulleted line beginning with the hyphen, and I have changed the font to Optima Regular 13, when I get to the end of the line and hit return for a new line, the program generates a new line beginning with the hyphen-bullet, with the cursor one tab to the right. But, when I start typing (without having manually moved the cursor) the text is Lucinda Regular 13 (correction from previous post, size is 13 not 14). This sounds like abnormal behavior based on what you said in your post.
I have tried setting up a new page with a bulleted list in the binder I have been using for the project. The first bullet works as you describe it should, the text is the default Optima setting. If I return and indent 1 level, the first bullet at that level behaves as it should, bullet is Lucinda, but text is Optima. However, if I hit return again and start typing on the next bulleted line at the second level the text becomes Lucinda. Just like the first two lines, I start typing where the tab leaves me off, with no manual movement of the cursor, beyond the initial return.
Is it possible there is something wrong with the package content itself? Some corrupted preference maybe? Is there a fix? I am using the English system.

If you create the bullet and then change the font, when you hit return, the next bullet is created in a font that matches the preceding bullet (in this case Lucida 13). So when you continue typing, the text will be in Lucida 13. So, be sure to change the font before you choose the list option to create the bullets. This behaviour is part of the OS X text system, by the way, which Scrivener uses - you can see exactly the same behaviour in TextEdit. In general, the way the OS X text system handles bullets (and tables) is, sadly, below par.
All the best,

Call me old fashioned but I still use ( Option + 8 ) to get this •

Call me old-fashioned, but I still use Asterisk-Space to make lists. :wink:

Same here, but that is because MMD will take care of it for me when I export.

Call me old fashioned, but I use TextSoap to create lists.

  1. Write out list without any adornment such as bullets.
  2. Copy to TextSoap.
  3. Apply one of my list making “custom cleaners”.
  4. Paste back into The Scriv.

Custom cleaners for this are simple RegEx find/replace which puts either a bullet or a hyphen or a choice of groovy unicode characters followed by a tab in front of each line except empty lines.

Call me old fashioned, but my wife makes list for me!

Pick up milk.
Clean the office.
Shovel again.
Grow up.

Oh, not those kinds of lists? Sorry.

My wife calls those the “Honey Do’s”. And when reading it I can always hear her voice…

“If mamma ain’t happy, nobody’s happy.”

Pace yourself though because the Honey Do’s are endless and ever growing…