Text gets invisible

I have a “File” in the Binder of which the biggest part of the text is invisible / not shown. The last visible line shows the horizontal half on top of the line visible the other half below invisible. The rest of the text below is not visible. I can mark the invisible text (in the usual way, somewhere in the white space where the text is invisible, the text stays invisible) and copy it and paste it e.g. in another “File” or “Folder” and it gets visible

The file looks like a “Folder” with horizontal dotted lines separating the sibling folders / files.

How could I get the text visible and avoid the text getting invisible? And why is the text invisible?

Edit: suddenly the text looks like this (after clicking another item in the Binder and coming back it is invisible again):

Edit: When I search for phrases / a word in the invisible text with the project search (field on the right on the top) the entire text is shown.

Hi Biff,

Try selecting all text inside the document, right-clicking the selected area, and choosing Text Color > Remove Color.

I hope that works for you!. :smiley: But if it doesn’t help, please post a screenshot so we can better see what’s going on.

Best,
Jim

Hello Jim,

Does not help unfortunately (I do not use text color there besides of black). And since a horizonally half of one line is half visible (the other is not), I guess, this cannot be caused by the text color.

A screenshot, alright:

Many thanks!

I’m not seeing that in your screenshot, Biff. Could you please show it?

Yes, of course, I will try to:

Hi Biff,

Turn on Show Invisibles. Perhaps you’ll get a hint there.

Does changing the font make a difference?

Worst case, I guess you can always copy from the problem doc into another. Otherwise, sorry, I have no ideas for you, :frowning:

Best,
Jim

Hello Jim,

Show Invisibles? Where is it? And what for?

Good idea: when I change the fonts or their size the entire text disappears or a bigger or smaller part of it or anything else happens, e.g. the text looks like this:

The text cannot be zoomed, it stays the same, same size.

No no, no reason to sy sorry, very glad about your help, Jim.

Many thanks!

Format > Options > Show Invisibles

This will toggle your view of the hidden control characters that Scrivener inserts, for instance line breaks or spaces. Perhaps that will reveal something flaky.

Although I’m starting to think, if the problem is just affecting this one document, then perhaps the doc has been corrupted somehow. That’s a round about way of me saying, I don’t have a clue what’s causing this. :slight_smile:

Best,
Jim

Probably the text has been copied from somewhere and still retains its original formatting and size. What I would do is I would copy it and paste it in a new document matching the style.

It then looks like this:

Copying the content (with the issue obviously) of the document to another / new one does not help, And some of the formating / paragraphs get lost. Many thanks anyway.

No, written in Scrivener.

Does not work unfortunaltely.

Have you tried copying the text into a simple text editor? That sould strip out all rtf formatting.

It looks as if you have line spacing less than single line, fixed to exactly a number of points. Are you using styles?

Yes, I did. After copying the text back the same problem.

Not that I know of. Not by intention at least.

Hi Biff,

Would it be possible for you to upload a sample of the project which illustrates the issue?

Asking because there are many variables at play here, and it would be far simpler to look at your settings in a project than have you list out everything in a post.

Prior to uploading, make a copy of the project, remove all documents except one or two which are having the issue, remove any personal information in the project, and zip it,

Best,
Jim

Hello Jim,

Yes, I will do so, thank you. I created a new project - without any of the original text / files / data of my project - and I could simply reproduce the issue. Very strange.

Hi Biff,

Thanks for sending the sample project, I also experienced the issues (text not visible or displayed in tiny letters or only half a line displayed).

I played around with it a bit, and apparently you’ve encountered some limitations in Scriv 1.9 Scrivenings mode.

It seems that when word counts in individual documents get into the 8k-9k range, 1.9 Scrivenings simply can’t handle it, and the result is that these display issues present themselves.

As a workaround, I would suggest you either avoid Scrivenings mode in 1.9, or make your documents smaller.

FYI, I could not reproduce this in the v3 Beta Scrivenings mode, which could easily handle documents of 60k+ words, so you won’t have this problem when v3 is released. :smiley:

Best,
JIm

Hello Jim,

Many thanks for testing. And great you found the cause.

Limitations…well…

Yes, I had experienced the same here, though with about 15.000, 20.000 words, do not remember anymore exactly. But I couldn’t imagine the issue really might be caused by the amount of words, it would have been too ridiculous, senseless. Very strange limitation, the amount of words / characters for a writing program lmited…hard to believe…sounds ridiculous, I would think.

Avoiding scrivenings mode? Such an important option? That is not so easy, I guess. And adapting the (structure of) the text / content to the limitations of an obviously poor / poorly pgramed program? So use more documents (not being needed / being superfluous)…I am not sure. What would be the best way doing that?

That sounds really good…may be there is another restriction then…a limitation of using the small “e”…at the end of a word…and the beginning…or such…or too long sentences…or…Adjectives…or spaces…or characters generally…

Thank you very much for your great help, again!

If you have several individual Binder documents with 8-9 k words, or even 15-20 k words (!), why would you need scrivenings mode? Scrivenings mode is meant to stitch together a large number of small documents so they look like one continuous document in the Editor. If your text is already a long continuous document, you don’t really need scrivenings mode.

Sounds like an extremely astonishing question. I would say, for most of the other items (not having “8-9 k words, or even 15-20 k words (!)”). And even if there are items having a bigger (than whatever) amount of words I wanted to use them with, see them in the scrivener mode (and not one by one).

Sorry, only because there might be somme bigger documents I actually absolutely would not think I would not need scrivenings mode.

People work in different ways, just because it’s different to yours doesn’t make it invalid. The good news for Biff is that the impending release of V3 will solve this issue.

People work in different ways, but if the text is one long continuous text, there is no need for a technique that stitch together several short documents to emulate them as being one continuous, is there? And if scrivenings mode cause problems, not using it in a situation where it isn’t necessary seems to be a simple solution.
… or splitting the text into shorter chunks to help scrivenings mode handle them.
L&L aren’t likely to do any major changes to Win Scriv 1.9 so avoiding problematic situations is a simple solution for those that don’t want to use the Win beta.