Text jumps too far when using arrow keys to navigate document / how to adjust?

I’ve using Scrivener 3.1.3 on a MacBook Pro running 10.14.6.

EDIT: Let me rephrase: the cursor is moving down to the next line of text as it should, but the “paper” is jerking up to reveal 7 to 10 new lines of text, depending on the line spacing and font size. It is as though the entire document is being advanced to reveal a few inches of new words instead of only showing me the next line of text when I hit the down arrow once. Same thing happens at the top if you arrow-key up once.

EDIT 2 AN EXAMPLE:

I opened the Scrivener Tutorial to “Start Here” document which appears the in the Editor.

On my screen, the last line in the Editor is: “designed for dipping into, so you don’t need to read it in order. Whenever you feel”

I put the cursor on the last line just in front of the d in “dipping”.

Hit down arrow once.

The document shifts up so much that now the last line of text in the bottom of the Editor is the heading, “Some Tips Before you Begin.”

That is about 11 lines of new text appearing after hitting the down arrow only a single time.

ORIGINAL POST:

Ordinarily, I write using an iPad with separate keyboard but am transitioning to use the MacBook. I cannot figure out how to stop the text from jumping so much as to be distracting when I use the arrow keys to navigate down through an existing document. This is happening both in the Editor and in Composition mode even though I have turned off Typewriter Scrolling.

What I mean to say is that if I am editing a document and want to scroll down a single line, but not use the mouse, I hit the down arrow once. Instead of moving down one line, the document jumps about a paragraph and moves the cursor up to the middle of the screen, moving the entire document up about a paragraph’s worth. Very jarring.

Cursor (and text) does not jump when I type, only when I toggle down a single line upon reaching the bottom of the screen.

I thought this might be an issue with typewriter scrolling so I turned it off in both the Editor and Composition Mode:

Preferences/Editor/

Box for “Typewriter scrolling always jumps” is not checked.

View/Text Editing/Typewriting Scrolling is also turned off (not checked)

Am I missing something? Thanks for any help you might be able to offer…

There isn’t actually a “scroll down one line” key on the Mac that I’m aware of. There is PgUp and PgDown of course, but that’s quite a bit more than one line. The arrow keys will move the cursor from one line to the next. What you’re describing sounds a bit like holding down the Option key and pressing the up or down arrow keys. That is the command to move up and down by paragraph. Are you saying that it’s impossible to move the cursor to the next or previous line at all? I’d suspect a stuck key or something, but I’d also try the same thing in TextEdit (rich text mode; no page view), which uses the same text engine as Scrivener (copy and paste a chunk of text from Scrivener into that, so that you have roughly the same conditions).

If it doesn’t do the same thing there, try a simple reinstall of the software. It could be something is broken with it somehow.

Thanks for the reply – I did a poor job of describing. Turns out the cursor is in fact moving only one line. However, the “paper” if you will is moving up by about a paragraph. 7 lines in my double spaced document, 10 in another I have that is 1.5 spaced.

So yes, I am hitting the down arrow key which should move the text down only one line. The cursor is only moving one line, but the “paper” is jumping about 7 to 10 lines making for a jarring effect. I’d expect to see only one line of text appear at the bottom of the screen if I hit the down arrow once.

The same is true if you use the arrow keys to scroll to the top of the screen. Same magnitude jump.

(Just to check, I tried opening a document in Pages and it does not do this. One down arrow moves the entire document by only one line as it should.)

It sounds like you may have typewriter scrolling turned on. To turn typewriter scrolling off, toggle View->Text Editing->Typewriter Scrolling. To change how Typewriter Scrolling works in general, try playing with the options in Scrivener->Preferences,… ,Editing panel, Options tab.

As I mentioned, Typewriter scrolling is turned off both for the Editor and Composition Mode.

Yeah, as you expect, it should only scroll if you’re at the very top or bottom of the view, and then by one line. I have no idea how to get the result you’re describing though. Sometimes we get weird reports like this—one person has the all usage of the trackpad acting like End/Home for example. I can’t really explain any of them, and there tends to never be a way of reproducing the problem on any other system.

Please try TextEdit. Pages doesn’t really have anything to do with the standard Mac text editing system. Apple’s too good for the stuff they leave for the rest of us to use. :wink:

One thing I’d like to point out is that this effect is happening on both of my Macs. Totally different machines: iMac and MacBook pro running slightly different versions of the OS, even. Scrivener installed at very different times.

I hope that someone in the forum will try the example I posted and let me know what happens on your machine. If you put the cursor where I mentioned (or your own bottom line in the tutorial) in the Tutorial and go down one line, does your page “jump” too? Maybe this is just standard behavior for the app?

I was considering doing a reinstall, but it doesn’t make sense that two independent machines installed at different times would display the same behavior if there was just a bug in a single install.

(Yeah I don’t actually use Pages for anything at all! I just opened it to see if I might have some kind of systemwide thing going on…)

Hi

I tried the experiment and observed the same behaviour. The cursor of course does move just to the next line. But to respond to Ioa, the same behaviour does happen in TextEdit.

Best

Ray

Oh! I misunderstood that this was happening anywhere you put the cursor (and my memory of what the last line does was off—attuned to how it always works). Here is what I tried:

  1. Opened a fresh copy of the tutorial.
  2. Pressed ⌘A and then ⌘C to copy all.
  3. Opened TextEdit.app from Applications.
  4. Pasted the “Start Here” document content into the window.
  5. Resized it so that the indicated line was at the bottom of the view.
  6. Positioned the cursor as described and pressed the down arrow.

It scrolls up a good 4 or 5cm. That’s just how text works on a Mac. :slight_smile: It does it in Notes, Scrivener, probably Mail (though I don’t have that set up so I didn’t check), even Stickies!

Wow! You guys are right. It happens in Mail (in a new draft), Notes, TextEdit… It even happens in OpenOffice.

Would you believe the only application where this does not happen is the one I tried at random? Pages? Pages works as it should, but nothing else will.

OK, I guess I’m going to see if I can track down some sort of fix/patch for the Mac itself to stop this behavior. It’s a real pain and shouldn’t be happening in a writing application–though I say this to Apple, not to Scrivener. I’ve been using Scrivener exclusively for all my writing for years, doing almost all the work on an iPad with keyboard so I just never noticed before now.

It would be great if there a way to prevent this from happening in future editions of Scrivener, but I understand that because this is default Mac OS behavior there may be no way around it.

Many thanks to everyone for helping me get to the bottom of this!

I found another thread regarding this issue in another writing product. I tend to agree with the original poster that it is really annoying in program meant for writing, but I don’t see that it was ever able to fixed. Just posting this in case anyone is interested. I’m not tech savvy enough to dig deep, I’m afraid…

bugs.documentfoundation.org/sho … i?id=46988