Text justified when compiled to .doc, not to .pdf

Hi there -

When I compile my project using Novel Manuscript Format it ends up left-aligned when compiled to PDF (which I think is correct) but justified when compiled to a Word document.

Is this a bug? It feels like it should be consistent.

Thanks!

This is happening to me with the latest version of Scrivener and Word 2010, in both .doc and .rtf. I have tried everything I can think of to get around it, including building the compile custom settings back up from another template. The only way I can get rid of the justification and back to the left-justify I need in order to submit my manuscript is to either cut & paste from Scrivener to Word scene by scene to skip the compile altogether or to paste my novel from Word into Notepad to clear all formatting, and then to paste back into a fresh Word document. This loses my other formatting, most of which can be reconstructed. Losing underlines is tough, though.

Has anyone out there found a fix for this? I see a few references to this problem from back in March. I’m under a time crunch and not sure what to do.

Thanks!

Note: This is most noticeable with Courier New. I can’t really tell, but it seems that it might not occur with some other fonts.

A few questions:

  1. In Word, when using Courier New, does Word show the text as fully justified in the formatting-bar, whatever, or is it still shown there as left justified? If it’s still showing in the format bar as left justified but the text is coming out looking justified, then the problem is with Word’s text engine when working with Courier New (and perhaps other unnamed fonts).

  2. Does the whole manuscript, including any titles, have any other formatting, other than simply the font? Could you not set up a new style in Word, which uses Courier New but is properly left justified, and then change all the body text to that style?

  3. Have you tried exporting to RTF and then opening that in Word? if your editor/whoever will only accept something with a .doc extension, you can then save it out as .doc. RTF is by far the best export format, and is fully supported by word.

I haven’t had Word since the much lamented, late version 5.1a, so I can’t go further than that, I’m afraid.

Good luck

Mark

Thanks very much for the response, Mark-

The problem shows up in both .doc and .rtf when opened in Word 2010 after a Scrivener compile. I tried selecting a single paragraph. The toolbar shows no justification selected at that point. However, when I then select left-justify, the justified appearance doesn’t change. Selecting any other of the justification options and then going back to left-justify also doesn’t help.

The other formatting in the document is just what Scrivener saves out in the compile. The contact information and word count are a table, and some chapter headings are center-justified.

I do have an update to this issue. I found through experimentation that if I select a paragraph and clear all formatting, the issue does not go away–once I resurrect the Courier New, 12 point, first line indent formatting, it goes back to justified. However, if I select all and paste into a new Word file, the text is properly left-justified as expected. This makes me think that there is something invisible being set at the file level.

Because that’s just a single cut & paste, it’s a viable workaround for me, but it took me quite a few hours to stumble upon. I don’t know if there is any spot that I might post the workaround if this sort of bug isn’t highest priority. I’d certainly like to save other folks the time.

Hi Amanda,

I’m glad you’ve got a work-around for the moment. Also, as soon as I had posted, I realised I was in the Windows forums and I’m a Mac user — I always check the Windows forums to see if there is anything I can help with … and then forget it is a Windows forum!

It seems to me that this is an issue you should take up with the team. Of course, this has hit you while they have all (supposedly) been taking a much needed break, but I’m sure one of them will check this thread in due course. If you want to make sure they know of it, send an email about it to windows AT literatureandlatte DOT com. I’m sure they’ll be interested. Just bear in mind, they’ll have a lot of catching up to do when they get back to work.

Mark

EDIT: And do remember to include information as to which version of Windows you are running, and which version of Scrivener.