Text not updated/viewable

I am typing using full screen mode . When I exit the text is not shown in the corkboard view, although the card title is there . When I search the text and reveal it in binder . It becomes viewable until I leave that location and have to search and reveal again.
I get a similar problem when finding the text created while the cursor is clicked on a folder. It will not show up until I click somewhere else and back . The problem is you forget you had text on that location and misleads by showing a previous state of uncompleted text ! I have had always this intermittent problem . I am using a sliver mid2008 MB with 10.6.2 and Scriv 1.52 . But I had this problem on other machines with previous versions of Scrivener and OS X 10.5.x . I have only now came across the full screen mode problem , since I rarely use it, but was always aware of the problem of text entry created while a folder is clicked. In the case of full screen mode will this bug is still there ! I think this bug occurs when you are working on a text file that has been converted to folder …not sure.

If you’re typing in the main body of a document, it’s not supposed to show up in corkboard view. The corkboard view shows the synopsis.

Or am I misunderstanding what you’re trying to do?

Katherine

What Katherine. The index cards contain the title and synopses for a Binder item (folders too), they do not contain the body text, though if you don’t want to bother with a synopses, you can open the Inspector and press the little button on the right-hand side of the index card you see there to automatically copy the first few hundred characters into the card.

Secondly, it sounds like you haven’t yet discovered that there really is no difference between folders and text documents. You can switch back and forth at will and it makes very little difference except when it comes to navigation (click on them) and some advanced compile options. Corkboards and Outliners are just a different way of viewing something, a way to see all of their children in an informative way. You can easily turn them off in the toolbar and read the text for the item as well. You can also set your navigation options to work in a method you prefer, if you’d rather things didn’t automatically switch to corkboard. Indeed, you can even put documents inside of other documents. Try not to think of the Binder in the way you’d use the Finder. It is much more flexible and lets you change your mind later.

If you haven’t already, you should go through the interactive tutorial in the help menu. It goes over all of this stuff and much more, and can be completed in about an hour. You’ll probably find a lot of new things out and improve the way you are working with Scrivener.

Thanks for the promp reply and I do appreciate your feedback. However, try this : create a text file with some synopsis . Convert it to folder. At this point I can see the synopsis but not the text (click some other binder item and come back to the folder). They only way for me to make the text viewable is to to do a text search and click on it from the result window on the left (where the binder usually is ). Some times even the text does not show up so I click on a different result then click to the previous location ). Once the text is visible in the result window I select ‘reveal in binder’ . Then it is visible for that one time only ! Am I doing something wrong or is this a bug when converting text to a folder !!

You’ve uncovered the ways in which folders and documents ARE different. As Amber said, both can contain text, and can contain other documents, so aren’t really that different. However, folders enable you to create particular kinds of workflows simply by virtue of Scrivener understanding that certain documents are also folders. (For example, Amber mentions being able to customise how a draft is compiled according to whether a document is a folder or not.)

The other difference is the behaviour of the editor when folders are selected in the Binder. With folders, you get additional interface behaviours that ordinary documents don’t give you. So, by clicking on a folder and failing to see the text inside it, you’ve simply opened the Corkboard view for that folder. Since the Corkboard can only show you subdocuments as Index Cards, you don’t see the text for that folder. (Note that folders containing text have a little “document” sub-icon, which makes it easier to see when this is the case.) To see the text in a folder when that folder is selected in the Binder, simply click on the Corkboard icon in the toolbar to turn the Corkboard view off.

There are two ways to globally change this behaviour:

  1. by going to Preferences > Navigation > “When in editor mode, open folders as…” and choosing “Using default document view mode”; or,

  2. going to Preferences > Navigation and unchecking “Excepting folders” under “Automatically switch back to editor mode when changing documents”.

There are good reasons for allowing users the flexibility of converting documents into folders, and also good reasons for automatically showing subdocuments of folders as Index Cards as the default. Your text within the folder is just made a little less obviously accessible when these two things collide.

To summarise: remember that there can be text inside folders, despite Corkboard view being the default view of a folder, and that you can easily switch out of Corkboard view; or, don’t make Corkboard the default view.

EDITED TO ADD: Just realised you might have had “Outline” selected as the default view for folders, but the point stands – both Outline and Corkboard views only show subdocuments of the selected folder.

It works as expected for me:

I had a window with four panes: Binder, text view, corkboard, and info.
I created a new file, with synopsis and body text. The text view showed the body text, while the corkboard remained blank. The info panel showed the synopsis.
I then converted the file to a folder. The windows did not change, except that the folder icon appeared next to the file name in the Binder, text, and corkboard views.
I then moved up a level in the corkboard view, which made the card and synopsis (but not body text) for the new file visible.

Again, the corkboard view isn’t supposed to show the item text. The text view isn’t supposed to show the synopsis. My copy, at least, is behaving exactly as expected.

As Amber suggested, you might want to work through the tutorial, which explains how the different views work.

Katherine

Ah yes, as Katherine notes more directly, if it’s not obvious by now, the Corkboard won’t ever be able to show you the text contained directly in a selected folder, because its job is to show index cards. If it were able to show you the text belonging to a folder AND the index cards of subdocuments inside it at the same time, the whole object-based metaphor would be broken, or at the very least incredibly confusing.

Hi,

Yes, as the others have already explained, the corkboard and outliner modes show the subdocuments of the selected document. You can turn these modes on or off via the icons in the toolbar or via the commands in the View menu.

If the inspector is open, you will indeed see the synopsis there. When you select a folder, it opens in corkboard mode by default (depending on your Navigation preferences). The corkboard shows the titles and synopses of all its subdocuments. So, for instance, if you have:

Folder A
   Subdocument 1
   Subdocument 2

When you click on Folder A, you will see index cards representing the title and synopses of Subdocuments 1 and 2 on the corkboard, because they are the subdocuments of Folder A.

The inspector will show you the synopsis of Folder A if nothing is selected on the corkboard, but if you select one of the subdocuments, the inspector will show you the synopsis and meta-data for the selected document.

If you click on the corkboard icon in the toolbar, you will turn off the corkboard and see the underlying text for Folder A. Most likely, there won’t be any text in it yet.

If you convert the folder to a text file, it will remain in corkboard mode unless you go to the corkboard icon and turn corkboard mode off.

If you click elsewhere in the binder and come back to the document, it will open as text rather than as a corkboard because the preferences, by default, are set to open regular files in the editor and folders in corkboard mode. So now that the file is a text file, it will no longer open in corkboard mode by default. But when you have selected it, you can still turn corkboard mode on by clicking on the Corkboard icon in the toolbar. Again, you will see Subdocument 1 and Subdocument 2 on the corkboard, as they are Folder A’s subdocuments.

If you click on a regular text file that has no subdocuments, you can still click on the corkboard icon to switch to corkboard mode (or the outliner icon to switch to outliner mode). The corkboard (or outliner) will be empty, though, because the text file has no subdocuments (but you can add subdocuments if you want).

No it’s not - this is a long-winded and unnecessary way of doing things. This is just a result of the Navigation preferences being set by default to open all documents in editor mode when selected in the search results table. But you don’t need to do this to see the underlying text. As already explained, just turn off corkboard mode - just click on the corkboard icon to deselect it.

I recommend checking out our tutorial video entitled “The Flexibility of Folders in Scrivener” on this page:

literatureandlatte.com/videos

This explains folders and their uses in depth, and should answer all of your questions.

Hope that helps.
All the best,
Keith

Thankyou very much to all of you for your feedback . I love this piece of software and it makes working on my Phd a joy indeed . I will take all your suggestions to heart, after spending so much time with scrrivener it is easy to assume that one has uncovered all its treasures. I going back to the drawing board and watch the tutorial to deepen my understanding of its flexibility . Looking forward to 2.0 !!