Text Not Wrapping in Word and PDF Compiles

I’m running across a strange issue when trying to compile to PDF or Word. My files look as I’d like them to look in Scrivener. There are some strange formatting things in the MOBI version (that I can most likely live with). But the PDF and Word versions have part of the text running off the right margin completely. It is like there is no wrap at all for those lines. This doesn’t happen often, but is scattered throughout my 90K word project.
This is an unusual project, as it is a cookbook…so not just page after page of block paragraphs. Rather, there are are styled headings, headnotes, endnotes, page breaks, etc.
Also, is there a way to surpress those annoying blank line separators in the those compiles as well? There is probably a way that I haven’t found due to my frustration with the above!

Hello.

Some ideas:

  1. Find one the errantly aligned sections in Scrivener and check that the margin markers on the ruler (CMD R to toggle on / off) are set to the page boundaries. This thread might help:

literatureandlatte.com/forum … php?t=8425

  1. Edit the compile format to remove the blank-line separators for the relevant section layouts.

Best.

For the improperly aligned sections, check for errant table formatting. The View -> Text Editing -> Show Invisibles command may help.

Katherine

Thanks to both of you! I think I got one problem solved, so I thought I’d share.

I changed the margins for the entire manuscript in Scrivener. Apparently, the right-hand margin was set close to 9"…and for some unknown reason, some parts of my text (but not all) adhered to that even through it ran off the page. Reset margin for all the manuscript using the ruler to 6.5" and problem solved in Word.

I’m an old Word user, and one of the first things I thought of was the old Word menu choice of “Reveal codes.” When I checked the invisibles in Scrivener, there was nothing obvious in the problematic lines/paragraphs.

I still cannot get those pesky ugly line separators to go away. I found in the global preferences where you could change separators for different things, but didn’t see one for blank line like the graphic above.

What version of Scrivener do you have?

Katherine