Text not wrapping

Hi,

I have bought a copy of ScrivMac and I am having trouble writing in the editor. My text is not wrapping to the next line, instead it is disappearing off the side of the screen.

How do I fix this?

I’ve tried tabs and indent settings but nothing appears to be working. I’ve reset to default settings but of course I have lost all my other preferences. I’d rather learn how to alter my custom ones.

Thank you for your help.

Two possibilities come to mind:

  • You have Page View mode enabled in the View menu. Since that uses paper size to lay out the text, if the window is narrower than the paper it will wrap off to the side a bit.
  • I’m guessing it’s some rogue formatting through. What I would try is using some text that is known to be okay, like maybe from the Tutorial, and click those settings into your Formatting preferences pane via the button above the mock editor. Then try resetting the individual documents that aren’t wrapping, either with the Documents/Convert/Formatting to Default Text Style… command, or if that doesn’t work, cut and then Paste and Match Style (after visiting another document first, so Scrivener flushes the old RTF that you left empty by cutting). If neither of those work, the settings must still be off, try manually moving the right indent marker inward, so you can see the text wrap in the Formatting pane, then slide it all the way to the right so that when you let go it kind of “bounces” back a few pixels. Now right indent should be off.

Oh, and welcome to the Mac side of the forum. :wink:

Thanks Ioa,

I managed to work around the issue by pasting text into text edit and copying back into Scrivener. This has solved the problem.