Text of manuscript disappearing

This was more of a heart attack than a bug but this seems the place to put it.

There was an update this morning from my computer at work, which I installed and then I opened my novel and was just gathering some information. Wasn’t even writing very much, just a couple of small edits. Then I saved the whole thing with a new name to dropbox becase I’m paranoid.

Went back later in the day to check some more informaiton for a synopsys and I realized all of the chapter icons were blank. I stared clicking on each chapter. No words. All of my words were gone.

I assure you I didn’t do anything stupid. I use this program regularly, between three different computers, my home desktop, my work computer, and my laptop, all linked to my files on dropbox. I’ve NEVER had something like this happen. Each of these computers is using Windows 7 and I usually install any latest update.

Once I saw this I closed this file, calmed down, opened my last save and was relieved to see all my words. I comiled to word to be sure my novel was safe and emailed it home in case it was something wrong with Dropbox. But I can’t imagine how. All of the chapter titles and sub-headings were still there and named. I think all of my research folders were still there too.

When I got home and booted my laptop I did not install the update from this morning. So far, so good.

I’m sorry this isn’t the most technical of reports. But if anyone has questions, let me know and I’ll answer them. I do actually do technical support for people with speakers so I understand the concept, just not what would be needed here.

Elanor

I’m sorry you nearly had a heart attack! It sounds though like you do have your whole project safe at the moment, is that correct? In which case we can at least try to diagnose the problem here in a slightly less frantic way. In addition to your saves and Word backup, the other first recovery step is to check your automatic backups from Scrivener. From the Backup tab of Tools > Options you can easily access the folder with your automatic backups, saved as a zipped archive every time the project is closed; copy out all of these (just for safety’s sake) and then you can unzip them starting from the most recent and open the project in Scrivener to find a copy to restore. (Make sure that you extract a copy of the project from the zip by right-clicking the zipped folder and choosing “Extract All” or by double-clicking the zip to open it and then dragging out the contained folder to another location; otherwise it will be in a read-only state and Scrivener will give you an error message when you try to open it.) Again, sounds like that’s not needed here, but it’s something to know in case of a panic like this.

For troubleshooting this particular problem, I’d like to start with a few clarifications if we could. First, you said you saved the entire project with a new name to Dropbox–I assume this means you did a “Save As” to save it there, and since you use Dropbox regularly, you ensured that the entire project had time to upload before you disabled your internet connection on the computer? Having Dropbox in the mix complicates the issue since sync errors are probably the most common cause of lost work (happily it often isn’t entirely lost), so I’d just like to be explicit on everything involved there. When you reopened the project and saw it was blank, was that on the same computer where you’d last opened it? And was that the newly saved file–the one with the new name, on Dropbox–or the previous version? Then finally, when you opened your “last save”, what file was that and where/how was it saved? (E.g. is this a backup you made via File > Back Up > Back Up To… or had you done another Save As to a different location at some point?)

For a little background, the way projects are stored, the project file that controls the binder and is essentially the backbone of the project keeps all the titles of documents and their meta-data together, linked to the individual document files that are the main text, the synopsis, and the document notes. Here it sounds like your project file loaded just fine but couldn’t find the actual document files, hence the text was missing. This could happen because the files were misnamed or in the wrong location (if another program manipulated the files, for instance). Alternatively it could mean that the files are there but aren’t displaying properly for some other reason, e.g. the RTF reader is experiencing a bug, or they could be there but the files have actually been wiped of their data, which is extremely rare–usually you’d only see something like this for one or two files in the case of a severe crash while they were being edited, and recent changes to increase redundancy should make this even more unlikely. Since you’d saved another copy in this process too, something could have gone wrong at that stage, where the files didn’t save correctly to the new location, so you might again have not gotten all the files or they might be there but incomplete or such. Answers the above questions might get us on the right track for trying to at least isolate where the problem occurred.

It was definitely a shock. But it looks like everything is safe. Extracking from backups is good to know, and I think I’ve foudn that before back when I was first learning to use scrivener.

The internet connection is never disssabled. At lesast not deliberately, and I never noticed it cut out while I was working. The whole office will tend to erupt into grumbling if it does. So I don’t think that was happening.

As for filenaming, I try to give myself a daily maming convention and then add on with a letter or number or something throughout the day with successive saves. Yes, this is through doing Save As, and choosing dropbox as the destination. Sometimes I’ll also pop oone onto the HD of whatever computer I’m on for exta backup as well. Better safe than sorry, enver know when all the words might randomly dissapear right?

Right before this started, meaning, the day before, I had done a small complie of just the first 3 chapters as a word doc, then today I went back and reselected all of the chapters again for compling. Could this have triggered something?

I’m just nervous about that latest update that I installed at work now. So far nothing has dissapeared on my laptop. Fingers crossed. Actually, I’ve just found that some of my reseach files have info missing and character info files where I had been dumping random character facts to refer back to.

When I am at work tomorrow I will check the backup file and see if the complete file is there and safe.

I’ve had a much to busy day at work to spend much time looking for why this happened. AI was able to check a few of the backups, and all of the backups from the hard drive here so far are blank. I think I’ll have to call them a lost cause and restore from a backup on my laptop tonight hopefully. Rather than try to restructure from the word doc since that will take a long time.

Any more thoughts on what caused this in the first place?

Ugh, I’m sorry to hear you had some other files that might not have survived–I hope you were able to recover them from a backup. We’re in-process investigating possible causes of the problem, so excluding any Dropbox-related issues, given you’ve been successfully using that method for a while now, the best guess is that it has something to do with your machine configuration and a slight change made in 1.5.6 and then tweaked a bit again in 1.5.7 for how work is stored in memory and saved to disk. The changes in general improve performance and reduce risk of losing work in a crash, but there may be an unaccounted-for small subset of machines where limited memory and hard drive space are causing this to backfire.

When you get a chance, could you check a couple hardware specs on your work machine (where the text went missing)?

  • Hard drive free space: Open Windows Explorer (Windows Logo Key + E) and right-click on your local disk drive where the Scrivener project is saved and choose Properties. How much free space is reported in the General tab?

  • Available RAM: Open the System Information window by right-clicking on the “Computer” item in the Windows Explorer list (parent of the C: drive) and viewing Properties or by using the shortcut Windows Logo Key + Pause key (also labelled Break). What’s reported for the Installed memory (RAM)? (Also, while we’re here, what’s the processor speed and system type?)

  • Paging file size: From that System Information window, click the “Advanced Settings” option and enter the administrator password if necessary. This will open a System Properties dialog, focussed on the Advanced tab. Please click the Settings button at the top for Performance, then in the Performance Option dialog that opens, click on the Advanced tab. The bottom section here is on Virtual memory: what does it give as the total paging file size for all drives?

Looks like the novel text itself is safe, so thats the important thing. The only thing I haven’t recovered anywhere is just those few character files. So, it could have been a lot worse I suppose.

I’ll get the information you asked for tomorrow morning and post it here.

You may’ve been through all your backup files already, but if these were older documents, remember you might be able to restore them from older backups or older saved copies of the project–just open that and the current project side by side, then drag the documents across from one binder to the other. If they were new there might not be another copy, but you could try the Windows “previous versions” tool to see if you can recover them from within the Scrivener project folder that way if you haven’t tried that already. (I’d make a zipped copy of the whole .scriv folder first as a backup before messing with restoring versions.)

Thanks in advance for the system info–I know it’s a a hassle, but all the information we can get on this will help track it down and fix it as quickly as we can. These sort of bugs are the worst in every way–absolutely horrible to experience and nearly impossible to find.

Quick clarification, on re-reading your earlier post–had you actually run compile at the beginning of the session that closed and then reopened blank, or did you open the compile window and make changes and then Save & Close, or did you just change the “include in compile” status for some documents via the inspector or outliner? I understand you had compiled documents the session before that one, but I’m not certain on what compile-related activities you performed at the beginning of the problem session and it would be good to know. Thanks!

I had done the compiling before that I think and I did it a couple of times because I was having troulbe getting just the parts I wanted. But that was just me not unchecking the right sections becasue I only wanted the first three chapters at that moment. Then I went back in later and rechecked everything for a proper compiling since I realized thats also how it does word count.

Here are the specifics on the system here. Our IT guy was just walking though the office and he’s assured me that we didn’t have any server or internet connection issues the day this happened. I also tried to explain what happened and he doesn’t think it was anything hardware related, but he didn’t have time to stay and take a look. I’ll show him more specifically when he comes back later to fix something else. (The something else is unlikely to be related to this, I just can’t open images that come from iphones for some reason on this computer. Very strange.)

There are 132 GB of free space on the local disk.
use space is 85.2 GB.

RAM 4.00 GB (3.46 GB usable)
Processor is Intel ® Core 2 Duo CPU E7500 2.93 GHz

32-bit operating system

Total paging file size for all drives is 3547

I’ve had something similar happening, but only with new parts of the document. I’ve got a project stored on my win7 PC’s shared documents folder. On that computer, everything’s fine.

If I try to access the same project on my laptop (win XP) through my home network, all the text I created prior to the update shows, but the parts I added recently on the Win 7 machine are blank. If I try to add text to one of those blank sections on the XP machine, close Scrivener, then open the project again, the text is lost - on both machines. If I add text to an older part of the project, created before the update, the changes remain - on both computers.

If I add a new part on my XP machine and open it on my Win 7 PC, that text is there. If I edit that part on my Win 7 machine, the changes remain, again on both machines.

Of course I never have the same project open on both machines at the same time!

It seems to me that the problem lies solely with parts of the project created on my Win 7 machine and accessed on my XP one.

Hope that helps you track the problem down!

Frauke - Thank you for the thorough analysis, though I’m sorry you should have suffered some lost work to share it! I hope you were able to recover everything from your backups on the Win7 machine?

The problem here is interesting and seems a bit different from the other reports, or at least different from what I was expecting and investigating. When you create a file in the project on the Win7 machine and add text to it, then close the project and reopen it on that same computer, is that file and its text still there? So the problem is explicitly opening that particular file on a different computer?

And to clarify here, when you say “parts” or “sections”, you mean entirely new documents in the binder, not just new text added to an existing document, yes? It sounds that way but I want to be sure!

Yes, sorry, I was referring to new documents added to an existing folder. For instance, I added a new document right at the top for the title page, with copyright notice etc. I created that on the Win 7 machine, and the text still displays on that one.

The XP machine can see that there is a new document called ‘title page’, and initially it displays with a little icon of a piece of paper with text on it in the binder structure. If I open it, the document is blank, and at that point the icon in the binder structure changes from a page with text to a blank page. All this happens ONLY on the XP machine, and ONLY with documents that were added on the Win 7 one! All document additions/edits done on the XP machine behave exactly as they’re supposed to, on both machines, and all edits of existing documents done on the Win 7 machine are fine as well.

I haven’t lost anything, by the way, everything’s present on my Win 7 machine, so not to worry! :smiley: