Text styles and Compile

Hello, several of my text styles compile accurately, but others do not. For example, I have a style marker called Chapter Sub-title with settings that dictate that the text be centered. When I compile to Word, it does not center this text.

Question 1. how does one insure that all of the text styles compile correctly to Word?
Question 2. how do you set additional parameters in text styles, such as “start new page” ?

Scrivener, unlike Word, is not a style-drive program, so it sounds like you might be expecting some things to work in a fashion that it isn’t really designed to be doing. For example, page break signals are inserted using attributes of your outline not your text. If you create a new text document and then open the Inspector (blue ‘I’ icon in the toolbar) then you’ll find a checkbox for “Page Break Before”, which means this section of text will start on a new page. It’s just a different way of thinking about things. In Scrivener the outline is much more important, and styles hardly do anything—in fact we don’t even call them “styles” specifically to avoid misrepresenting them.

Even more useful than this however, and more in line with what you are thinking of for using styles to determine document structure, is the Separators pane in the compiler. There you can tell the system to insert breaks according to the “shape” of the outline. A common example (and a default for nearly every pre-built format) is to use folders to generate such section breaks. This happens automatically, without the checkbox I mentioned above. There are other options as well, such as inserting a page break in between each text file in the list.

As for the first question, I would recommend going through Step 17 in the interactive tutorial (Help menu). There are some fundamental concepts described there that might bring some clarity to how this program is designed to work. Briefly though, it sounds like you’re using a compile preset that formats your text—and you don’t want it to format your text. So the easiest answer is to use a preset that doesn’t do that, such as “Original” from the Format As compile drop-down.