Text width in compiled text

My first story in Scrivener 2…

When I compile it the text comes out in a very narrow column, only about 6 words wide. I can broaden this by editing the content box limits once I get to Word, but how can I set it up to compile to a proper width inside Scrivener?

Also, when I try to export similarly to Pages I only get one page of the main text and then the document ends. I guess this is an issue with Pages RTF support, but this wasn’t a problem at all in the previous Scrivener. I try to avoid Word when possible, and had achieved that with Pages and Scrivener 1, but this just doesn’t seem possible with the new version. What’s the problem?

First question: Compile, Page Settings, Margins and “Page Setup…” (button the right side of the panel). Fiddle around with your font and your page size so you get the width you need.

What version of Pages are you using? Pages '08 has a nice bug where it doesn’t always notice that text has been added (at least I found this under different circumstances, not involving Scrivener). You can put in a carriage return or otherwise force Pages to repaginate, and it finds the lost text. I found other bugs involving Pages '08 and Snow Leopard that all went away with Pages '09. (Of course, Apple doesn’t give a discount for upgrading)


And if page margins are not a problem, you might also have a constrictive setup in the Formatting pane for compile. If the right-indent has been dragged way over to the left, this would result in a narrow page.