Textdocument jumping up and down after editing

OK, the title sounds strange but my english is not sufficient enough to describe it better. Let my try: When I open a textdocument in Scrivener (I usuall have the textdocument next to the binder, then on the right side the corcboard and far right the inspector) and when I then enter some text into the existing textfile and after hitting enter, the textblock is jumping up. This makes it uneasy to focus on the new text as I do have to search for the cursor. It looks like it jumps a full bench.

Is this a bug or a feature? And is there something that I can do to avoid this behaviour?


This sounds like you have typewriter scrolling enabled. From your description it doesn’t sound like you’re in fullscreen mode so to disable this feature, go to Tools -> Options -> Editor then untick “Typewriter scrolling in new projects.”

Have you enabled typewriter scrolling in the editor?

Hi all,

thanks for your ideas, but the function “typewriter scrolling” is disbaled, means, unticked. So this could not clarify the behaviour. I found per searching in the forum, that in version 2.2 for Mac, the issue is also advised. (literatureandlatte.com/forum/vie … ng#p114098)

Any other ideas?


Hi Peter,

Just to double-check, could you click in the editor where you’re getting the text jumping to place the focus there, then go to Format > Options and see if typewriter scrolling is checked there? Disabling this in the Options as mentioned above will ensure that it is not turned on by default for new projects you create but won’t affect the setting in your existing projects. Additionally, this can be turned on and off per editor within a project, meaning each split can have its own setting as can full screen. You’ll need to disable it for each of the editor splits where you’re seeing this.

The Mac and Windows versions use different code, so the bug in the thread you linked is likely not affecting issues in the WIndows version. In that case also the typewriter scrolling was enabled, and the bug had to do with that mode rather than not being in the mode.

Dear Jennifer,

I have applied the update to version 1.0.3 and since then, the issue seems to be gone. I have tested on several devices (laptop and PC) and also with different textfragments, but the “jumping” is over …

I will monitor the behaviour and give a shout, if it pops up again.


This jumping problem persists in the Windows version Even though Tools/Options/Editor/Fullscreen typewriter scrolling in new projects is unchecked, the jumping still happens. It’s an existing project that was created when the option was checked. Apparently I don’t know what a “split” is, because I can’t make it stop jumping. It does work for new projects.