The document could not be opened... (variation)

Like a couple of others, I’m having some problems after the upgrade to Scriv 3. I deliberately held off as I didn’t really need anything more than I already had, but any excuse to put off doing any writing, eh?

Anyway. It’s biting me. After the upgrade I had a quick look at the tutorial project - then I used the ‘Find of type- Scrivener project’ command under File. I selected an old project - it said I needed to upgrade. A few whirrs later Scriv says
‘The document … could not be opened.’ No further message.

I tried a couple of other projects, and the same thing happened. I tried a couple of projects I don’t care about and bingo, it opened.

Unfortunately on the ones I do care about I can’t edit them at all. They’re old - 7-8 years old. There’s no permissions issue I can see (I set Everyone to have Read-Write access on it and same thing persisted.

A variation of the message I’m seeing is the below. (Ellipsis replace stupid folder names)

I have done this, and there is no .scrivx document (although all the RTF files are there to keep me sane). This looks to have been an upgrade problem - is there a way to fix this?

Is it possible that the problem projects were last opened in Scrivener 1?

If so, you’ll need to do a double conversion. First open in Scrivener 2 to convert to that format, then open the result in Scrivener 3.

Katherine

Possible, but I can’t check. I ‘replaced’ Scriv rather than a separate install. If I uninstall 3 will 2 magically reappear or do I have to reinstall 2 as well?

You’ll need to reinstall Scrivener 2. If you replaced it when you installed Scrivener 3, it’s gone.

Katherine

Ok, thanks Katherine.

I reinstalled 2 and upgraded various projects, I then upgraded Scriv to 3 alongside; and for the most part that appears to be working (not bulletproof though).

So I’m hoping that the ticket can be closed.