The https link issue

Currently, if you add a URL to text and it’s an https:// link, it won’t work as a clickable link (even if you paste the block of text+link elsewhere).

You can just take the “s” out, for a regular old http:// link, but I often forget, and more and more sites are defaulting to https://

Is this something that will be fixed in future, or is there a reason it has to be this way?

If you use a non-HTTP protocol for the URL, then you need to use the “No Prefix” option in the link window. The other options are for when you aren’t typing in a full URL and want help with the specifics. Typing or pasting in your own protocol on top of the prefabs will results in links like, “http://https://blahblah.com”.

The next major update won’t be as strict about HTTP and HTTPS technically being different protocols.

Thank you! That’s very helpful to know.

Also great to hear that the next update will be less strict! Particularly as more and more websites seem to be using https these days.