The Missing Link

I have just come across an odd behavior with Scrivener, for the second time. I have a link to an external document in a Scrivener document. I dragged a text file I use to write and keep my tag logic, into Scrivener. It looked like Scrivener should be able to manage keeping such a link. Alas, not.

It did work when I first dragged in the link. It still worked after I saved the Scrivener file, closed it, and reopened it. But after it sat on my HD for a week and was just opened now, it won’t work at all. And, this is the second time it has had such a link stop working after I opened it again - not right away but, at some point.

What it looks like is this, the link still appears as text and it still looks like the same link that used to work. But clicking on the link only sounds my Mac error beep. It does not launch the file.

Right clicking on the link and selecting “edit link” does … nothing.
Right clicking on the link and selecting “open link” does … nothing.

In the same Scrivener document I have a link to another external Scrivener file. This Scrivener link still works as before. But the one for the text file, no longer works. It did when I first tested it. It worked after closing and reopening it, but not anymore.

As this has now happened twice, I thought it wise to ask if anyone knows why this is happening?