The new pussycat and split windows

Having been forced to spend yesterday sorting a mountain of papers into numerical order, I set my MBA to download and install Mountain Lion. Apparently all went well and smoothly apart from one minor matter, and a problem with Scrivener 2.3.1 …

Since I am working on translations, I always have Scrivener running with a left/right split. In the left hand split, I have the text I’m working on, with the source or snapshot of the original translation I’m editing in the right split. In one of my projects, and I’ve only looked at this one so far, I cannot change the document without removing the split first. If they’re both open, binder clicks only change the right split.

Previously, when working on this project, I had the navigation preference set so that binder clicks would affect the editor when the left split was locked in place. I have turned the preference off, the left split is not locked — blue header — but nothing will change in that split as long as the right split is open.

Screen Shot 2012-07-31 at 09.14.43.png
Anyone else found this?


Edited to correct typo in version number … confusing with new version of NWP.


I’m using the same setup (i.e. Mountain Lion, Scrivener 2.3.1). I use the same layout as well for translations.

I’ve just tested it on an old file and I can’t replicate the problem. i.e. When the preference is turned off, clicking on the binder affects the selected document as normal, even when the split is in place.



Thanks David, so it’s clearly something in my set-up, my project. If anyone has any ideas what to look for, I’d be really grateful. It’s a bit of a PITA, having to shut the second split just to change the text in the first.


OK, as we were. After a lot of faffing around, I went to and selected the saved “Translation” layout and that seems to have cleared whatever was causing the blockage, so all is back to working normally, thank heavens.


Good news…

Hi Mark,

I believe you must have set View > Binder Affects > Right Editor at some point. The “Binder Affects” setting gets saved into layouts, so switching to a layout without this setting would have cleared it.

All the best,

Hi Keith,

Thanks. You may be right, but I don’t actually remember ever doing that. In fact, I’ve just looked through all the menus to discover where you can set that switch and I didn’t see it with my earlier faffing around.

Anyway, reverting to the saved layout solved it … I only have that one saved layout!

And now that’s solved, things seem to go really well under ML and 2.3.1.



I have a different problem when using vertically split windows in OSX.8.0:

When using script mode (UK Stage Play) and trying to split windows vertically, I gett just one column of letters on each side.

I can reproduce this every time. Console says:

19.08.12 19:44:58,639 WindowServer[93]: CGXDisableUpdate: UI updates were forcibly disabled by application “Scrivener” for over 1.00 seconds. Server has re-enabled them.

19.08.12 19:45:00,553 WindowServer[93]: reenable_update_for_connection: UI updates were finally reenabled by application “Scrivener” after 2.91 seconds (server forcibly re-enabled them after 1.00 seconds)

Splitting horizontally works fine.

See attachment for an illustration of the problem.

Best, Jolanth.


Regular text files (i.e. those that are not part of the stage play) get messed up, too.

Showing the inspector pane makes text in the right window disappear completely.

Again, this is reproduceable, Console says:

19.08.12 20:07:53,599 WindowServer[93]: CGXSetWindowListAlpha: Invalid window 0

19.08.12 20:07:54,600 Dock[4544]: CGSReleaseWindowList: called with 12 invalid window(s)

Don’t know if this is related to Scrivener.

Update 2:

Here’s another strange one: Full Screen (not composition mode) and two vertically split windows. I move the cursor to the left edge of the screen, Binder slides in. But it doesn’t slide out anymore. The only way to make it disappear is to type something into the text on the left split window.

Console says:

19.08.12 20:44:10,453 WindowServer[100]: CGXRegisterWindowWithSystemStatusBar: window b already registered

Hi Jolanth,

I’ve been away, but hopefully someone has already got back to you via another support channel and you haven’t been left hanging for nine days. If someone has got back to you and resolved this, then please ignore this reply - if no one has got back to you, then please accept my sincere apologies. :slight_smile:

Your main problem just looks as though you have “Use fixed width” ticked in the “Editor” preferences (probably along with “Full screen only”) and a narrow editor width set.

As for the binder sliding out again, if the binder has the focus (if you click into it) it won’t slide out until you click into the main editor. It only slides out automatically if it doesn’t have the focus. This is intentional, as it would be annoying if it slid out when you were using the keyboard to move things around in the binder just because you knocked the mouse.

The console messages you received look like harmless (but annoying) window server error messages that Mountain Lion generates all over the place, and not specific to Scriv.

All the best,