The return of the .doc/.pdf bug, no options in Finder

Okay, this is weird. With beta 2.0, I can drag and drop doc files into Scrivener on my laptop (Toshiba, running Windows 7 Professional 64-bit) but not on the desktop Acer (running Vista Home Premium 64-bit). This is opposite of the situation I originally had with Beta 1.7 and 1.8.

I can import doc files on both machines using the Finder, but cannot drag and drop doc files on the Vista machine. This time, I don’t even get a null entry when I drag and drop. Nothing happens at all.

Worse, I can’t import PDFs at all on either computer. Drag and drop doesn’t work, and I don’t have any options in the Finder except Text (*.rtf *doc *.docx *.htm *.htm *mhtml *txt). I can’t switch to “All ()” and there are no other options.


You can switch to “all”, just by typing an * in the filename box.
You can also type .
To get access to a particular file type, write *.rtf or *.pdf, or *.doc or *.docx, or whatever extension you need.

The import functions do work (at least on Win7 Home Premium).

It is only the “shortcuts” to the filetypes that are not visible.

Type them in, and you have them.

Why are they missing? They were available via dropdown list in the three previous versions I used (betas 1.7, 1.8, 1.9).

Well, that half works as a kludgy temporary work-around. I type * or .*. in the file name box, and I then do get a list of all the files in a particular folder, including .doc and .pdf. I can then select a .doc file and it will import, but I still cannot import a .pdf. I can select it and click on “Open,” but nothing happens.

That’s on both Windows Professional 64-bit and Vista Home Premium 64-bit.


First of all, it is better to type . than .*.

Explanation : * means “anything”

Filenames are “anything” [dot] “anything”, and never [dot] “anything” [dot].

About importing pdf in particular, I have myself experienced many difficulties to view the files.

You can import pdf’s only into the research folder.
And in my experience, you can only view some of them.
This is a weird thing on which I have posted at least once or twice : Import of pdf is not always working ok.

In some projects, I have no problems, in others, I cannot import and view any pdf.
What I can see in these cases is a blank page, with no text at all, and a page count of O/O.

And this is not depending on the pdf, as some are visible in one project, and not in another.
And it is not depending on the size of the project either, as some pdf do not import properly into a quite new and empty project, although they will open fine in another project, a huge one…

This time, I tried importing one, and it works fine…

Err… As far as I can remember, I started missing them from 1.8 on, at the time where *.doc and *.docx files became available (withouth having the import working properly yet).

Now doc import works PERFECTLY.
I tried that yesterday.

And “how” they came to disappear ?
I can only guess : These guys are working hard for a very complex thing as it seems to me.
And many of us come with their information and wishes…
With so many things, I can understand that some minor one can be forgotten sometimes.

Sorry, I was still not entirely awake when I wrote that “why” post and thought you were one of the mods. It’s just frustrating that things that were working or had been fixed in the previous beta is broken in this one. I appreciate all they are doing and am loving this program in general. I’ve been talking it up to my writer friends and planning to buy the finished product when the time comes.

This has mysteriously fixed itself. I now have the “Any ()” option again in Finder, and I can both import and drag-and-drop both doc files and pdf files. This is on both the Windows 7 Professional 64-bit laptop and the Vista Home Premium 64-bit desktop. I don’t know why it didn’t work before, but it didn’t, in numerous tests. I’m glad it does work now.

I can´t import PDF files even on beta 20. The error I reported earlier still persists.