The wonder of Time Machine

Over time I have had my iTunes library corrupted a few times (I have no idea why). Having roughly 15,000 tracks in my library, the thought of having to redo all my playlists, ratings etc. is infuriating, to say the least.

So, with the advent of Time Machine I thought problem solved. Low and behold, the other evening my library again became corrupt. (I do know it is always the xml file that is at fault).

With excitement, and a certain amount of ‘up yours iTunes!’, I delved into Time Machine to get my last saved copy of the xml file and bring my iTunes library back to life. :smiley: But hold on :open_mouth: the xml folder doesn’t appear in the previous hourly save, nor, it seems, the previous hour. Back, back, back… neither is it in the previous days, week, month!!! Where the hell is the only file I want? Everything else is within the folder, why not my xml file? :cry:

That’s not good! What are your Time Machine settings? I just checked, and it appears that my iTunes XML file has been backed up at a very frequent rate this whole time, so I don’t think it is a general bug with Time Machine. I haven’t actually restored to verify (as I like my current XML file very much), but you are saying it isn’t even showing up at all.

Hi Amber. No the xml file does not appear at any point throughout the entire history of Time Machine’s startup (This is several months). I run it in the background, standard hourly backup, so find it quite strange that the first time I need it the only file that appears unavailable is the only file I need. :confused:

Try this: Using the Finder go to the drive you are using for backups. You’ll see Backups.backupdb at the top level. Go in there and find a folder alias called ‘latest’ at the bottom. This should give you a folder structure of your backed up drive. Navigate to your user folder and find where the iTunes library file should be. If it is there, you know how to get to older copies of it as well using the dated folders instead of ‘latest’. If it isn’t there at all, that is pretty strange.

Thanks Amber. Okay, have just tried that and low and behold the xml file does not exist anywhere within the Backups.backupdb. I had an idea that maybe the file was not being backed up because I pretty much have iTunes permanently on. I backed up with it on, re-entered Backups.backupdb, still no xml. Next I turned it off then backed up. Yet again no xml. Last try, I physically opened the xml file and changed it then saved so time machine had to be able to see it had updated. Looked in the Backups.backupdb and the only file missing in the itunes folder? You’ve guessed it, the xml file. :open_mouth: