Time insert?

Hi,
I want to be able to insert the time without the date. Is there a way of doing this? Please treat me as if you were dealing with a very young child who is far from being computer literate :smiley:
Any help, guidance, would be much appreciated.
martin.
p.s. I have searched through the forums but no luck.

WordService can insert the time (you can create your own keyboard shortcut, if you want to).

itunes.apple.com/gb/app/wordser … 2312?mt=12

Don’t think that a time-only service exists in Scrivener.

Slàinte mhòr.

Thanks for your suggestion. I’ve downloaded Word Service from the iTunes link but I’ve no idea what to do next :smiley:. I did what was suggested i.e. opened my systems preference, then keyboard, shortcuts and services. It lists several Scrivener things but I haven’t a clue which box to click.
I am pretty clueless regarding anything technical. I’m from the era when we communicated with two cocoa tins and a length of string (didn’t work going round corners!)
I’ve been using Scrivener since last June and, until recently, it was possible to insert only the time as well as date and time. There’s a greyed out box called ‘media time stamp’ so I don’t know if that’s something to do with it.
It seems to me that a time only insert is quite a basic and simple thing to have. I keep a journal and, apart from using the date and time each day, I don’t want to add the date each time I make an entry on that day.
If you have any thoughts, ideas, or further suggestions I’d be most grateful.
m.

Hi.

Nearly there. You need WordService > Insert Time.

And then assign your own keyboard shortcut (which doesn’t conflict with any other existing keyboard shortcut, for example CTRL OPT SHIFT T).

Slàinte mhòr.

Thanks very much. I clicked the word service time box and added the shortcut you suggested i.e. control, option, shift, T. But nothing happened when I tried that in Scrivener. I appreciate your help and patience but I think it’s probably easier if I just type in the time myself! I checked my journal entries again and there was definitely a time insert until earlier this year.
m.

Hi.

Sorry that it doesn’t work. It should appear as a menu item and be a working shortcut.

Slàinte mhòr.

Yes, I understand that. When I open Scrivener and place my cursor on services it shows ‘no services apply’. It seems I’m doing something wrong when I’ve clicked on WordService in services and entered the shortcut. Perhaps there’s an ‘apply’ that I’m missing? This is all a bit “Houston I’ve got a problem” level for me :smiley:

Hi.

Mmmm, Major Tom, this is Houston, is the cursor actually in the editor? Services can only apply when a suitably functional part of the screen / an app has focus.

Slàinte mhòr.

I do feel like a schoolboy who’s trying his best to get his homework right to please his teacher. It’s moving into the territory of me not only failing to find the answers but also not understanding the questions! :unamused:
Anyway - here’s a screenshot which, I hope, shows the greyed-out section. I’ve hovered my cursor over every available area but without getting in feedback.
A child of 5 could probably succeed in this! :smiley:
Screenshot 2019-02-01 at 18.26.42.png

I think your problem may be that the shortcut you’ve entered may be one already used by Scrivener. I tried with a shortcut to “Insert Short Date”, and when I tried it the “Document” menu flashed.

I checked with the list I made some years ago of all the shortcuts in Scrivener, listed in order of the final cipher/glyph*:

Mac Scriv keys by cipher.pdf (49.1 KB)

and changed the shortcuts set for that to Cmd-§ and “Insert long date” to Cmd-±, and entered an unused one for Windows - Mac line endings. When I went back to Scrivener, my Services menu was fully populated and worked.

:slight_smile:

Mark

  • I made the list while I was using Scrivener v. 2.x and haven’t updated it to reflect any changed shortcut settings for v.3; but it gives you something to start from.

Hovering is no good. Services usually act on something you have SELECTED, like text, or an image, or a file. So try clicking in a text field.

Morning.

Mark speculates that there might be a conflict for CTRL OPT SHIFT T, but I can’t find one on my installation of Scrivener, although personalisations might well cause local conflicts.

However, we could try a different keystroke, such as CTRL OPT CMD / (that’s CTRL OPT CMD FORWARD-SLASH). You just need to select the old keystroke combination and type in the new one.

And then, as mbbntu says, for the service to work, the cursor needs to be in an editable area: so if the cursor is flashing inside a text document in the editor and you press CTRL OPT CMD /, the current time should be inserted for you.

And if you should be interested in a list of Scrivener 3 shortcuts, see:
https://forum.literatureandlatte.com/t/scrivener-3-macos-shortcut-cheatsheet/42254/1

Really hope it works for you.

Slàinte mhòr.

Just checking that the WordService entry for Insert Time is ticked (as in the image above) so that it is active as a service?

Slàinte mhòr.

Hallelujah! Yes, indeed, control, option, command, forward slash works!
Well, with your help and clear guidance, others contributions too, I’m now able to insert the time with easy to remember commands.

Many thanks,
best wishes,
martin.

Glad it works as you need it to. Perhaps there was a conflict with the first keystroke combination, as Mark surmised. Apologies if there was.

Slàinte mhòr.

And he sews the outline of a yacht into the wind
And he sails away
With silver yarn roiling in his wake
And golden thread embroidering his course that lies ahead