Timelines / Timeframes

For those of you wanting something for timelines …

I tried several different writing software products recently before finding Scrivener. One of them, WriteItNow, had a timeline feature of sorts but it was so arduous to use and visually goofy that it may as well have not existed. So I began writing my own. About halfway through I found Scrivener for Windows and changed my effort to support only that.

It’s called Awrit and you can view screenshots and/or download it here down at the bottom:

rusnam.org/software/software.html

Awrit is written in Java Swing so it may work with all platforms Scrivener supports. I’ve only tried Windows XP. There’s a howto.txt in the zip file that explains how to make it go.

Please send any feedback directly to me. My email address is on my website, first page.

Merry Christmas,

Al

Thanks for your post (and your work)
I will try it :=)

Wow, thanks for doing this.

After an hour with it I reckon it could be very useful to me but there are a couple of show-stoppers:

  • Awrit assumes that my Scrivener draft folder is structured in ‘chapters’ and ‘scenes’, and only assigns times and locations to the scenes. I structure my work differently, with four or more levels of file/folder. I would need to assign times to files and folders on all levels of the hierarchy, and would need an option (eg a checkbox) to exclude a scene from the timeline.

  • Awrit adds its time and location data to a file’s synopsis. I use these synopsis fields intensively in the corkboard, and this data would get in the way, and I’d be liable to corrupt it. I understand that user-definable metadata fields are on the way for Scrivener - wouldn’t it be better to keep Awrit’s time and location data in these when they arrive?

And a couple of niggles:

  • As a Brit I really need my dates in dd/mm/yyyy format rather than the US yyyy/mm/dd :wink:

  • I unpacked the Awrit folder into my Program Files directory, and followed the instructions in the howto.txt file. I ran the batch file, the shortcut was created, but Awrit would not run. It took me quite a while to work out that it had set up the shortcut incorrectly - the quotation marks were missing in the shortcut’s Target line. I suspect most users would give up before they worked this out.

But thanks again, and well done. I hope you persevere and can put up with the many useful / maybe-not-so-useful suggestions that you will no doubt get!

Well, I think Simeva is right on one point (and maybe more ^^) : I tried to follow the howto.txt file and I gave up… Make the program work seems a bit too complicated for me unfortunately.

i’m not clear on what awrit is supposed to do. do i understand correctly it’s an aid to keep up with the action/sequence timeline of a story? if so, that would be a great addition. i’m working on a bit that covers a large time frame broken down into short stories taking place at different places in that time frame.

Ok, I think, maybe, I’ve fixed the ‘blanks in the path’ issue.
Awrit Version 1.1 is available here:

rusnam.org/software/software.html

You should be able to see it work with the tutorial now, hopefully.
To use it with your own projects you’ll have to copy and modify the shortcut or maybe make your own batch file.

I don’t know how most people are starting Scrivener but I use a couple of shortcuts. One is in the tool tray or quick start or whatever it’s called; takes only 1 click and always starts my current project. That’s because it has this command line in the shortcut:

“C:\Program Files\Scrivener\Scrivener.exe” R:\almnov\tgcontact.scriv\project.scrivx

The other shortcut doesn’t have that last argument and it starts whatever project I used last. From this you can see that with several shortcuts you can go directly to any project and not have to wait for project A to load before selecting project B from the Recent Projects list.

To respond to some of the issues raised about Awrit …

Awrit does add a line to synopsis files. That line has 4 items needed to record the timeframe for a scene. The line is appended to the synopsis file and will be deleted and reappended whenever a scene’s timeframe is changed so it will stay at the bottom. You can edit the line if necessary. It doesn’t seem like a big deal to add this line (earlier I had 4 lines and I didn’t like that so maybe it is a big deal).

I chose this method over modifying the scrivx file for several reasons. 1) Modifying the scrivx file may introduce bugs into Scrivener. 2) Java’s DOM classes, when writing the scrivx file, changed, without harming, almost every line in some manner, mostly reordering the attributes, thus making it nearly impossible to determine if the changes I wanted to make were actually there. 3) Scrivener can change the scrivx file format and break Awrit and I don’t want that. Right now all I do is scan the scrivx file for titles in 2 areas of the binder, Draft and Places.

In the future I may change to using a single file to record all Awrit lines. I think I avoided that method because I didn’t want to add anything to Scrivener that wasn’t already there. Like a file. Adding a line of text to an existing file isn’t that big a deal. Note that Awrit will not create a synopsis file; you must do that. I didn’t want to be messing with other people’s stuff any more than absolutely necessary.

Awrit supports chapter/scene and part/chapter/scene styles. I’ll have to look at my source but I think it’s treating every ‘leaf’ text element as a scene. Which means that parts and chapters are not treated as scenes because there’s more “under” them. So if you’re using some other format Awrit may not work, right now. If your work doesn’t fit those 2 formats and I think Simeva is one such, send me something on your binder layout and where you keep scenes and I’ll see what I can do. Maybe I’ve assumed too much here.

Awrit uses yyyy/mm/dd HH:MM for the absolute date/time format. My experience is that that format is common throughout the world except for the USA. I suspect that most people use mm/dd/yyyy HH:MM because their computer came that way. I use yyyy/mm/dd because it sorts properly due to its major to minor structure. I’ll have to think of a way to allow that to be changed because I really want to stay away from having modal dialogs. Also, different formats can require text fields to be much longer. Right now they’re not quite long enough to fit really big relative date/time. Also, I see most of the fields showning relative anyway.

Future –
I’m still thinking about the best way to graph Location vs Time vs Scene. Right now Location plays a very minor role despite the fact that one of the first things Awrit showed me about my own project was that I had missed defining about 20 locations.

I’m also thinking about not having the graphical timeframe dragging change to absolute time.

Al

Thanks for the explanation, Al.

I’m still experimenting with different structures, and I suspect that the way I use Scrivener will change as projects evolve. Here’s one example of a four-level structure I’m using for TV drama:

Episode/sequence/scene/notes&alternatives

Ideas for a sequence usually get written before all the scenes within it, so I would want both the episode and sequence levels to be included in the timeline. The ‘notes&alternatives’ get shunted elsewhere as the dialogue gets written, but while they are there I need to exclude some of these ‘leaves’ from the timeline.

So my ideal scenario is that I get to choose whether each level is included in the timeline (and I can give each level time and location attributes), and then I can over-ride that choice for individual elements.

As for dates: the British standard if you’re using numbers only is dd/mm/yy (or dd/mm/yyyy). You also see ddd mmm dd yyyy (eg Weds Dec 14 2011), but I don’t think anyone uses yyyy/mm/dd (or mm/dd/yyyy), except where they are forced to by their computers.

As for adding the data to the synopsis: well, it’s going to be a personal opinion whether it’s a big deal or not, but for me all those curly brackets look like garbage messing up my story - sorry!

Here’s another little thing: when I use the mouse to move things around in the graphical timeframe screen, the mouse is not properly co-ordintated with the element it is dragging. The mouse appears to move twice as far as the element.

Thanks Al,
Still can’t launch it. I have this message error when I launch the Awrit-tutorial shortcut :
“Unable to access jarfile C:\Program”

Just installed the last version of Java as described in the howto file…
I’m running on Windows 7.

Zack,

In the Awrit batch file, makeshortcut.bat, replace the mkshortcut.exe line near the end of the file with this line:

.\mkshortcut.exe “%scname%” “%wd%” “%icon%” “%idex%” “%javaexe%” -jar “”%jar%"" path=""%wd%\tutorial.scriv"" draft=Draft

The change is the with the quoting around %jar% if you want to replace just that ‘word’. Notepad will work for this.

Let me know if it works.

Al

Simeva,
That’s a unique arrangement you have. Do you think it would be useful for each level to constrain the next level, time-wise?

On the dragging, the difference in mouse movement versus “time allotted to a pixel” causes the time bars to move at a different rate than the mouse. Usually the bar moves slower. It’s an issue I’ll revisit.

Al

For the working method I’ve described, this would be a useful option.

Option being the key word. From the couple of months that I’ve been using Scriv, it’s clear to me that there are many, many ways to use the program, and its users are writing many different kinds of stuff (novels, theses, recipe books, film-scripts, religious tracts…). So any constraint that fits with one user’s needs may be a problem for others.


Youch, that’s a tricky instruction for Zack! With all due respect, Al, not many people are going to try this if it looks like you need to do some programming to get the installer work.

The way I got it to work was:

  • run the .bat file
  • do ‘right mouse / properties’ on the shortcut that is created
  • do ‘right mouse / copy’ on the contents of the Target field (the bit that is highlighted when the properties dialogue opens)
  • open an editor (Notepad, Scriv) and paste
  • make sure that the file location strings are in double quotes. There are three of them, usually beginning C:\ - but it could be D:\ or another letter if your computer is set up differently.
  • copy and paste it all back into the Target field on the shortcut properties dialogue
  • save
  • run the shortcut

Using an editor isn’t strictly necessary, but it helps you see what you’re doing.

Yes, thanks Al, that works.
I’ll try that as soon as possible!

Wonderful auxiliary tool!!

However, installation is nerdy!! Took me 1/2 hour to get it running!

Also, I didn’t have “Places” in Scrivener. It kept complaining about that until I finally figured out what it wanted.

Now all is good.

Thanks
Doug

I’d like to ask how this would work for a 64-bit version of Windows 7. :laughing:

I’ve been in software too long to claim something will work on a platform I’ve not personally seen tested. So the best I can say is that Awrit should work on any platform supporting Java 1.6 and that the Java people say it will work. There may be some visual differences due to each platform’s window manager.

I’m only able to test on Windows XP using English so that 's the only platform I can claim works.

The Java language supports 64 bit entities and the JVM is compiled for the platform’s bits, 32, 64, whatever. Awrit has no register/bus width limitation.

Al

It does …

Okay, so how does it work with the that OS should have been my question. It wouldn’t find the right javaw.exe (or whatever file that’s supposed to be) file when I tried it since those programs are in different places once you get past XP.

Ah ha. If you can type at a command prompt:
java -version
and get valid results such as “java version …” then java.exe and, most likely, javaw.exe is in your path. You can modify the shortcut’s Target line to have nothing before the javaw.exe (where it now has C:\WINDOWS\System32). If for some reason that doesn’t work try searching for javaw.exe using MS’s search scheme, whatever that’s become. You’ll probably get something like C:\Program Files\Java\jre6\bin\ for the location of javaw.exe. Put that path in the shortcut Target before the javaw.exe.

Let me know what happens.

Al

I think the problem lies in the fact that when I did go browsing for the java exe file, I found mulitple instances of it in a few different places. Since I’m running a 64-bit operating system, there are two Program File directories: one for 32bit applications (Program Files x86) and one for 64bit apps (the regular program files directory). I can also find the same named file in the Users/Appdata/whatever folder. I’m just trying to figure out which one I would redirect the setup file to go after.

i may have missed the response to my question, but i don’t think so. thought i’d try again.