TimesNewRoman PSMT font problems

Hi all, i have a suspicion this problem is not unique to Scrivener but i will ask it here anyway in the off-chance that it is, and if not, perhaps someone will know how/where to redirect me for help.

I have been doing the usual write in scrivener, export to a word doc, and then send the file to my pc for final touches and off to a group of directors i work with. They have been quite frustrated with me as each time i send a document, certain quirks come up, such as certain letters like ‘i’ being auto-capitalized. I have tried playing with and troubleshooting and what i seem to think the problem is relates to the fact that my documents, which on the mac i thought included TimesNewRoman as the font, on the PC show up as TimesNewRoman PSMT. Googling this doesn’t bring a lot of clarity. What i seem to gather, however, is that the PSMT is the apple version of this font family; am i correct? If this is the case, then i would assume the quirks i a getting in these docs are nothing to do with Scrivener, but is in fact a limitation of sharing docs between a mac and a PC. If that is the case though, i would be truly astonished that any time i wish to work between the two, because they don’t share the same sub-species of TimesNewRoman i am going to run into problems. Someone please rescue me from such an unbelievably absurd predicament!

Hi,

I do not know an answer, and it appears strange to me that a font should be responsible for auto-capitalising. But if so, why don’t you just change from Times New Roman to another font?

Best,
Maria

Have you tried Scrivener Preferences>Text Editing, un-ticking the Auto-capitalize box?

cw

Are the capitalised "i"s and so forth only visible in the files exported to PC? Or can you see them in Scrivener too?

Thanks for the quick feedback. I have investigated a bit further. I may be wrong but it does seem to be coming from Scrivener. Here is what i have learned: If i open Word on the mac, the default font is set for “Times New Roman”, and naturally these files when moved to the PC have no problem.

Any document i produced by exporting from Scrivener (whether in a .doc or in a .rtf format), and whether the font settings are native to that file or are assigned by way of the ‘format override’ feature on the export menu, i get a document in Word that looks the same, except that if i look at the font, it reads as “TimesNewRomanPSMT” every time. This is also irrespective of which document i export. I have tried reconfirming/changing the font settings in Scrivener, and they say “Times New Roman”. When the doc is opened in Word, however, they show as this other font. So, the problem isn’t between mac and PC Word versions, i don’t believe. Either it is unique to my version (faulty install, etc.) of Scrivener, or possibly the font family included in Scrivener isn’t the same Times New Roman used by Word. Previously i had thought perhaps it was just the incompatibilities of mac and PC, though i doubt that is the case now.

Is anyone able to reproduce what i have done to confirm what font is outputted upon exporting from Scrivener. If you could read out the font name that shows up when opening the doc in Word that would be appreciated.

Keith, Amber: are there any other steps i can try to pinpoint the problem?

Having looked into it, I can confirm this oddity, but it seems to be a problem with the RTF saving in OS X in general rather than with Scrivener. Try creating some text using Times New Roman in TextEdit, for example, then save it as RTF (it must be RTF and not DOC) and open it in Word - you will see the same thing.

However, I’m still not sure that this is responsible for the capital letters issue you report. As far as I understand it, TimesNewRomanPSMT is just the real, underlying name of “Times New Roman” anyway, so there should actually be no difference in the appearance…

Best,
Keith

As a pretty much non-expert, can I ask some basic questions?

(1) What machine and what version of the operating system are you using?
(2) What is the history of that operating system? In other words, as an example, I still have my old 400Mhz Rev1 TiBook which started out with System 9, was upgraded through all subsequent upgrades, then into 10 and on through to 10.4.9 while having Classic (9.2) there for loading when required. What this means is that there are versions of fonts on there that came with the older systems, which are still apparently working normally – including Song.dfont which I can’t install on this MBPro, 'cos of an apparent conflict with PostScript – including font number conflicts between SIL Phonetic fonts and Chinese fonts dating from System 9 days. So, is the TNR PSMT a legacy font from an earlier system installation?
(3) On that basis, do you have another version of TNR installed on your system as well. I use Linotype FontExplorer X, which gives much more information than FontBook … the standard 10.4 version of TNR it seems is TrueType; PSMT sounds like some flavour of PostScript font (I have those on my old machine … legacy fonts … they still work fine even under 10.4.9, but I’m not exporting from there). PS=Postscript, MT=Monotype? I seem to remember MSOffice installs various fonts … but I haven’t used Office under OS-X, so can’t be sure. Could MSOffice be expecting to have access to a different version of TNR which has or hasn’t been installed?

Fonts always seem to me to be a potential source of nightmares, so these questions are just those of a real amateur thinking around the problem.

Mark

Keith, you are correct, replicating this with Textedit creates the same problem. The same doc opened in Word on a PC or on a Mac shows the font as TNR PSMT. Regarding the stange behaviour of the capitalilzed i’s, this may be due to certain word plugins and templates, etc. bundled into the corporate environment of the computers i am having to work from and send to. The point seems to be though that where there is TNR PSMT there are problems (for me at least). I guess the question that follows then, is whether there is any sort of work around to export/output my work and have it come out as TNR itself. I suppose if i export as RTF or as Word .doc, and as html i will get the same problem. I tend not to export as html as it makes a bit of a mess of any bullets i have created in scrivener.

my directors are suggesting that i am using more complicated ‘tools’ than need be and should just resort to working from Word on the PC. I am still hoping and holding on, knowing the many benefits of writing in Scrivener. Yet if i accidentally send another file that generates autocap 'i’s it would look really bad.

By the way Keith, brilliant job on the copy & paste from and into Scrivener/Word with annotations. In the latest version, this works perfectly.

Can you see this strange behaviour on your Mac version of Word? Or is it only apparent on the PC version that your colleagues are using?
Thanks,
Keith

Word changes a lower case i to an upper case one by default unless you go into AutoText/AutoCorrect and change it. (Obviously, I’m referring to the letter i alone and not in a word. :wink: )

Could the problem be there?

hi all, no it is not a case of typing single 'i’s which Word automatically reads as pronouns. It is any word beginning with an ‘i’, oddly enough. This behaviour only takes place on the pc though, not on the mac. Although, again, the TNR font variation shows up identically on both. This is why i think this font variation is simply having a bad reaction with whatever corporate templates/add-ins/auto-correction/etc. things that have been bundled into Word. For my purposes though, this would effectively mean my not being able to use Scrivener.

I have done further testing, and strangely if i export as html the outputted font is no longer this TNR PSMT variation, but is the standard TNR. I had previously tried exporting as html many versions back and it seemed to me that there was some degradation of formatting. Can anyone confirm what limitations i might run into if i export to html: will all my bulleted and numbered lists output as they should? will footnotes, annotations and endnotes all output correctly? will ‘tabs’ and indents remain faithful?

many thanks all,

as i think the problem is unique to the internal network of PCs i interact with, i doubt others can reproduce the capitalizing ‘i’ effect (even if you could, like Keith, produce the TNR PSMT font variation). But for what it is worth, i am uploading a sample document.

Again, how this behaviour is brought on is by putting the cursor at the end of any word, create a few additional spaces, and then in the midst of the spaces try typing various words that begin with ‘i’. Though i doubt it will produce anything, if someone can try the document and confirm that they don’t have any such problems, i would appreciate it.

I am quite confident the behaviour is not virus-related.
114test.doc (29.5 KB)

That’s really weird. I opened it on my work PC and got the same behavior you did - EVERY word I typed that started with ‘i’ was capitalized!

This did not occur, however, after I went to Tools–>AutoCorrect Options and turned off ‘capitalize first word of sentences.’

This behavior also did not occur on my Mac with this same document, even with the capitalization option turned on.

I don’t have a PC, but I’d suggest trying a couple of things:

  1. This is a long shot since I have heard of no side-effects related to the file extension you give an RTF formatted file (what Scrivener exports). However, try changing the extension of the exported file to “.rtf” and then open in Word for the PC (with the default Autocapitalization setting in place). Does that make a difference?

  2. again, change the extension of the exported file to “.rtf” and open the document in Word for the Mac. Make some minor change, save it, and then open it in Word for the PC. Does that make a difference?

Either of these alone could be a pragmatic solution for you depending on your situation, but I’m also hoping for some clue about what is happening (in the case of #2, the clue might be in the RTF itself).

Bryce

Can you post the original Scrivener exported RTF file, an RTF version of the file Word/PC saves (without changing the autocapitalize setting), and an RTF version of the file Word/PC saves after changing the autocapitalize setting?

Bryce