Tiny spelling check bug

Try typing “etc.” and it will be flagged as incorrectly spelt; right click on it and “etc.” is one of the suggested corrections. Click on that, to use it as a correction, and “etc” is still underlined in red to show that it’s mis-spelt. But if you add “etc” to your word list, the underlining goes away. Trivial, but odd.

That’s a little odd, because “etc” is in the dictionary Scriv downloads, and should not be flagged as misspelt.

And it isn’t flagged that way for me, even using Scriv’s normal dictionary (which I usually don’t). Try re-downloading your dictionary?

Just did. Same result. Perhaps it’s because I’m using the UK English dictionary, not the US one?

So, shifted to using english-en-gb, and got the same error.

“etc.” is in there. Not “etc” like the US one has.

I edited the dictionary (en-gb.dic, in C:/Program Files/Scrivener3/hunspell/dicts/English-en-gb/), using Notepad++. Searched for ‘etc.’ and changed it to ‘etc’. If you do this, you should exit Scrivener before editing the dictionary. This will make your life slightly easier.

However, if you want both entries, you can add an entry. If you add a new entry instead of merely changing the entry, you’ll need to go to the top of the file and increment the number you find there by 1. So 46174 would become 46175 (the total number of entries in the file). After my edit, ‘etc.’ was no longer redmarked.

Hope that helps?

Many thanks, but it’s even easier just to add “etc” to your personal word list.

This appears to be a glitch in the U.K. spelling dictionary, since exactly the same thing also happens with “e.g.” and “i.e.”