Title separated from text after compile

When I compile, scrivener takes the title of my piece of text and inserts it right above the text. This is good. But sometimes this happens right at the bottom of the page, in which case I would like the title to start on the new page.

Like this:
h t t p s : / / monosnap . com/file/cnscY0JRgVNGhCOm2Miv7B0NMbTsTY

Here are my settings:
h t t p s : / / monosnap . com/file/4sNACTY4dEb8mPPrkGu0hhwuL24zoR

Is there a setting that makes sure the title always appears on the same page as the start of the text?


PS. Somehow I could upload the screenshots in my forum post, but I couldn’t post it if I embed images…

PPS. Somehow I can’t include links either :frowning:

Welcome to the forum, koppelaar. The inability to post screenshots and links is due to a security setting because you’re new to the forum. That will be changed as you post and interact more.

I recommend verifying that the Section Layouts you selected on the Main Compile screen have a header included. Then, within the customization area, check the Separators options to ensure that you have a page break before sections.

We also have a 4-part video series titled “Getting Your Work Out” on the Mac tutorial videos page. Those videos demonstrate using the built-in compile formats as well as show the customization process. Seeing them might be helpful.

I might very well be talking through my hat here, but, isn’t that what the widows and orphans feature you Mac users are so lucky to have is intended to prevent ?

Try Format/Paragraph/Keep with Next.

Hi Ruth,

Thank you for your reply. The thing is that I don’t want a page break before the section. I only want that when the title would be the only thing to appear on the page. I basically just want to keep the title together with the text. I’ve customized much of the compile process already. Just couldn’t figure this one out.


Thanks :slight_smile: Do you know where this feature can be found? I tried googling it, but that didn’t really lead me anywhere.

Thanks. I tried it. I put the title in the text as a Header 2 (instead of making scrivener use the name of the text document as the title), and checked if “keep with text” was selected, which it is. But still it appears that way.

Screenshot of the setting being selected:
https :// monosnap .com/file/g3ftWieXlowHBHiPVMwV8FY2XA9eNN

So not sure where that leaves me. It appears to me that this would be a common issue. No one wants their title to sit by itself at the bottom of a page, right?

Definitely, what you need is the Widows and Orphans protection to be turned on.

It’s in the text layout pane of your compile format.
. . . . . . . .

And here is an excellent and free screenshot tool. :slight_smile:
– Hmm. Sorry. Cheap, not free, on mac.

Found it. And this solved it. Thanks so much!

I have such a tool, but I couldn’t take a screenshot while using my mouse to keep the menu open. Hence the photo :slight_smile:


Anyway, thanks a lot for your help!

1 Like

That app I suggested would fix that for you. :wink:

I can even make a screenshot of me making a screenshot (lol) :

…or of me making a screenshot of me making a screenshot :

(This is fun… I should keep going.)


Haha wow, this tool really solves meaningful life problems :stuck_out_tongue:

Somehow another widow/orphan made it into my PDF:

Does anyone know how this can happen with these settings?

This should prevent it from happening, no?

How did you define the space between the end of a chapter and the title of the one after ?

(Perhaps you’ll have to insert a page break here and there, where needed.)

As single returns:

Yeah, I figured as much. Although it seems like avoiding this scenario is the intention of the widow/orphan feature, which makes me wonder: could this be a bug or am I misunderstanding the feature?

What I think, and the reason why I asked about how you defined the space between the end of a chapter and the title of the next one, is that if your title end up being a big chunk of “page space”, it might just end up not being considered a widow at all.

It could (maybe) also be the very opposite, where the chapter would have “held on” to the title of the next one. (Turning the title into an “orphan” of his.)

I can see from your screenshot that you have more space between the end of a chapter and the title of the one following than a single return…

Unfortunately, being a windows user, I have no way of testing anything. (We don’t have that feature in yet.)
I can only rely on other users past experience, and that’s about it. @AmberV

Ahh okay!

I think it’s so much because I set the paragraph spacing for these headers to 28 points:

This makes me appreciate your help even more :slight_smile:

Thanks so much!

I think your problem is here :
You are making the title too big of a chunk for the feature to consider it a widow and do its job.

Personally tho, at this point I’d just insert a page break at the end of needing chapters, in the editor, rather than to change everything up.
→ You could even insert the page break all alone in a doc that you would duplicate as needed and add in the binder right after the needing chapters. (This way it will be easy to know to which chapters you added a page break, and to which you didn’t.)

Adding page breaks will only be a problem if you later compile to a different page size. (In which case you’ll simply have to do a new visual check of the compiled output, and add or remove the page breaks as needed. – Keep in mind, though, that adding (or removing) a page break affects everything that comes after ; next chapters and all, up to the next encountered page break.)

To do it properly on the other hand (hypothetically still, as in “assuming I am right”), you’d have to set what you have as “space before” for your titles as “space after” for the last paragraph of your chapters instead ; and maybe even the “space after” of your title as “space before” for the first paragraph of your chapters.
(But even then, I am only 60-70% convinced it’d work better.)

Another solution would be to have your titles directly inside the documents, and use keep with next on top of the widow/orphan compile format option.


On the Mac, why not use the Screenshot tool in your Applications/Utilities folder? Among other things, it has a delayed capture feature so that you can open menus or whatever.