Titles in ToC Appear as Unknown

Scrivener has decided that it would be fun to change all of my chapter titles upon compile to “Unknown”.
It gets more fun, just wait.

In the compile window, if I check “page break before” in the contents section and leave “as is” blank, it gives me my chapter titles.

BUT! There’s always a but…

I lose all my formatting.
I don’t have special formatting in my manuscript, save for italics.

If I include “as is” upon compile, it does everything perfectly and beautifully save for the table of contents where it renames all of my chapters “Unknown”

The only thing I can think of is the beta is causing this (I downloaded the beta to resolve another issue I was having). My only thought to fix it is to make folders for every chapter heading and place the chapter inside.

Is there a better way? Making 20 folders sounds really tedious!

It sounds like what you want isn’t to check “as-is” but to deselect “Override text and notes formatting” in the Formatting section of Compile. That will leave the formatting from the editor (to the extent possible with ebook formatting) for all documents in compile, while also allowing you to include other elements (synopsis, notes, etc.) and a title prefix or suffix if you wish.

“As-is” is intended for special cases where you want to override the editor formatting for most documents with just a few exceptions. Documents marked “as-is” always compile only the main text, regardless of compile formatting settings; that is, it also overrides element settings like choosing to include just titles and synopses and exclude main text. If “as-is” has been set for a document, it will ignore that and still compile just the main text.

In this case, even if all you want to compile in the manuscript is the main text, you want to preserve the editor formatting for everything, so rather than checking “As-is” for each one*, just disable the formatting override and you’re done. The “Original” preset is a good place to start if you mostly want to just compile maintaining your editor settings; that doesn’t add any extra title prefixes like chapter numbering or even include the document titles themselves. (That won’t affect them appearing in the auto-generated TOC, but whether they appear within the compiled manuscript.)

For a document to be included in the ebook table of contents, it needs to follow a page break (i.e. a section break). This is most easily set in the Separators pane of compile; if I recall your screenshots correctly, you probably just need to set the top Text/Text separator to “Page Break” to have each document as its own section. Setting page break before for each one will work too, but like “as-is”, that’s really intended for the occasional case where you want the page break instead of what the normal separator would be.

  • You can turn “as-is” on and off in bulk by Alt-clicking a checkbox in the Contents section of compile or in the outliner if you’ve turned on that column. This works for Page Break Before and Include in Compile as well.