TOC formatting

Hi

I’m having troubles with TOC formatting in a document.

Although I’ve managed to make the TOC look ok in preview mode (see screenshot), it still compiles awfully (other screenshot).

Where do I have to start to get that TOC formatted right? Or is there someone that could “debug” that document for me?

Cheers
Urs
Bildschirmfoto 2016-10-19 um 23.16.18.png

It looks to me as though your compile settings lack the necessary tab stops to format the ToC correctly. In most cases it will be easiest to opt out of compile format override for sections of text like the ToC which are heavily dependant upon paragraph and font settings not used elsewhere.

This is easy to do, just select your ToC in the binder and in the “General” section of the Inspector, enable Compile As-Is. Now it won’t get an automatically numbered heading (1.1), you’ll need to supply your own title—basically the content and formatting of this section will now be up to you.

Yes, got it, thanks a lot!!
That hint was very helpful, super!